Copying & Pasting - Remove Source Formatting

Cbowers10
Member | Gold Partner

It appears that there has been a recent change, now when I copy and paste from an outside source the formatting from that source is being carried over. It is doing this in both blogs and website pages. It wasn't doing that just a couple weeks ago. Now I'm having to go through the extra step of pasting the content into Notepad to remove the source formatting before I paste it into Hubpot. I'm not sure why this change occurred, but it is very frustrating. If anyone else is struggling with this it would be great if we could find a way for the problem to be resolved.

10 Replies 10
PamCotton
Community Manager

Hello @Cbowers10 

 

Could you please provide us what are the steps you are taking in HubSpot to paste the source? Is in a Rich text or inside the blog module?

 

. The more information, screenshots, and details you can provide, the better I can advise on the next steps.

 

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




0 Upvotes
Cbowers10
Member | Gold Partner

Hi Pam,

I use the Inline Edit Mode (WYSIWYG) to create the blogs. I copy and paste the text from a Google Doc. Previously, when I pasted the text it would match the website's styling/formatting (font style, spacing, color, etc), but now it brings the styling/formatting with it from the Google Doc. So the font styling remains what it was in the Google Doc, and if text was a certain color it remains that color when I paste it. Just a couple weeks ago this wasn't happening. It does this if I paste from a Word doc as well.

 

The only way I've found to remove the formatting is to use a simple text editor like Notepad. The issue is, that then takes away things like header spacing and bullet points that are in the Google Doc. I then have to go through the entire blog and adjust the headings, adjust spacing, and add bullet points.

 

This also occurs if I go to edit an existing website page. If I login and paste content to a website page it brings the styling/formatting with it. It wasn't doing this previously.

 

Thanks!

 

Crosswalk
Participant

Seeing the same here. 

The text looks super odd when pasted through (from the same template doc we've always used) and when you look at the code some (not all) of it is surrounded by span style or paragraph style code which is overriding the defaults. 

 

I have to go through and manually remove it. 

 

Using paste values gets around this (or as the OP mentioned, using Notepad as a go between), but then I have to go back and find all the links etc to add back in, which can take just as long. 

 

It worked just fine before, not sure what's changed. 

 

 

PamCotton
Community Manager

Hello @Cbowers10 ( apologies for the delay) and @Crosswalk 

 

Could you please provide us a screenshot of what is happening in your end?  The more information, screenshots, and details you can provide, the better I can advise on the next steps.

 

Thank you,

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




0 Upvotes
Stapper
Participant

Pam, it's quite simple. Can appreciate you need screenshots but if you just read this thread and MANY others just like it, it'll be apparent and obvious this is a running issue with the HubSpot email system.

 

One cannot copy and paste from various other programs (Word, browsers, etc.) into the HubSpot email CMS without all sorts of of formatting irregularities, inconsistencies and FRUSTRATION!

 

Here are more threads similar in nature, you don't need screenshots to know there is a problem and to understand what is going on here. This is an age old problem with WYSIWYG editors and we expected better of HubSpot, a supposed Cadillac Solution we were told.

 

0 Upvotes
PamCotton
Community Manager

Hello @Stapper, Thank you for providing your feedback, when we mention sending screenshots, it's important for us to investigate based on images that is happening on your end specifically. 

Could you try selecting the pasted text in the email and click the remove formatting button 

 

clearformatting.png

 

At the moment the copy/paste for images works in the chat widget, but not in the Inbox. In the Inbox, only drag and drop works. The product team that is looking after the copy/paste for images in the Inbox said they’re actively working on it, so it won't be too long before it becomes part of the tool.

 

Also I would recommend @RSchmidt suggestion to copy and past, and upvote the idea you shared above.

 

Kindly,

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




RSchmidt
Participant

For mac users, CMD + SHIFT + V. 🙂 

HDurham
Member

@PamCotton this is definitely a terrible issue and was made worse by the recent conversation update. We used to copy and paste from outlook/word into hubspot and it worked fine in the "conversations" pop out window however now that's no longer possible due to the new update. 

I even tried copy and pasting a hubspot email into a hubspot email and it still destroys all the line breaks from the Enter key. See screenshot. It's super annoying and added about 5 mins to each email we are sending until we can get things more automated. 

First picture is what i tried to copy and paste second picture is the result of pasting. 

HDurham_0-1621285179831.png

HDurham_1-1621285370521.png

 

 

0 Upvotes
PamCotton
Community Manager

Hello, @HDurham just want to confirm what is happening on your end, we tried to recreate this and couldn't. Currently, the copy-paste feature is working. Is the problem that on long emails the linebreaks are inconsistent?

 

Thank you!

 

Pam

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !




HDurham
Member

Hi Pam, 

Yes copy and paste works but it doesn't format correctly with line breaks whether you copy from Hubspot or any other source. It used to in the pop up and now there is no option. 

0 Upvotes