Error: "Can't create inbox for this user"

Hi @JSanchezLiu,

Thank you for reaching out to the Community!

We usually see this error when HubSpot is unable to connect to the corresponding server on the given port. This could be because the server host name is incorrect and/or the port is incorrect.

Could you please disconnect your inbox, log out of HubSpot, clear your browser’s cache and then try to connect your inbox again by following these instructions (via “Advanced options”)? Thank you!

Please also make sure that your IMAP & SMTP information is correct - you can find instructions how to check them in this article. Most but not all IMAP ports should be 143 or 993 and most SMTP ports should be 465 or 587.

Cheers
Mia, Community Team