Sales Integrations

ABishop2
Member

Salesforce Sync Issue

Hello HubSpot Community!

 

We're noticing our Contacts in HubSpot are syncing to our Salesforce CRM as both Leads and Contacts. I've looked in our integration settings and cannot seem to find the location where we only select integrate the records as "Leads" and not "Contacts" at all.

Can someone help me with only sending all the records from Hubspot to Salesforce as Salesforce Leads?

Thank you,


Andrew

0 Upvotes
2 Replies 2
Phil_Vallender
Most Valuable Member | Diamond Partner
Most Valuable Member | Diamond Partner

Salesforce Sync Issue

Hi @ABishop2 

 

That sounds odd - the HubSpot connector should not be creating two records in SF.

 

The settings for which object type the connector will create for a new HubSpot contact are in the intergration settings' contacts tab:

SF sync.png

 

As you will see, you can only choose leads or contacts. Both isnt an option. 

 

The sync wil always dudpe, using email, against both leads and contacts, and update either if they already exist. But if your system is creating two records at the same time, something else must be going on and we might need some more information. 

 

I dont think it's possible (except perhaps under business units), buuuuut, if you had two connector instances attached and configured to do diffferent things - that could explain it. You can hopefully rule that out very quickly. 

 

Hope this helps?

Phil Vallender | HubSpot Website Agency
ABishop2
Member

Salesforce Sync Issue

This is what I see Phil.

Screenshot 2023-10-16 at 10.56.37 AM.pngScreenshot 2023-10-16 at 10.56.32 AM.png

0 Upvotes