Unable to create Calling API settings

SOLVE
Kamil_A
Member

I'm working on HubSpot calling extension and according to official docs here:  https://github.com/HubSpot/calling-extensions-sdk#get-your-app-ready-for-production

I should be able to send POST request to create calling settings.

 

curl --request POST \
--url 'https://api.hubapi.com/crm/v3/extensions/calling/352688/settings?hapikey=DEV_API_KEY' \
--header 'content-type: application/json' \
--data '{
"name": "VoIP service",
"url": "https://www.test.com",
"height": 350,
"width": 200,
"isReady": true
}'

 

But when I send POST request I'm receiving following error:

 

{"status":"error","message":"Writes to call settings data only accepted on api.hubspot.com","correlationId":"2e2e581b-50f6-49ae-bf9d-afedbcc52742"}

 

How can I send those settings from api.hubspot.com? There is nothing about this requirements in documentation and should be able to POST it from my server. 

 

Thanks! 

0 Upvotes
1 Accepted solution

Accepted Solutions
sduane
Solution
HubSpot Product Team

Hi everybody! This issue is now resovled.

I really appreciate you both dropping a note about the Calling Extensions API not working with an application owned by an EU1 portal.

There was actually a bug in this specific service, which is now resolved. Give this API another shot, you should be good to go!

Sorry for the trouble!

View solution in original post

6 Replies 6
dennisedson
Community Manager

@Kamil_A ,

Your code is good and should work.  I believe this is an issue associated with the hapikey issue reported here.

I see you are already on that thread.  We are close to deploying a fix

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
YaminiBisht
Participant

I'm facing the same issue. I've checked the hapikey as well. Also, please provide an update of this thread https://community.hubspot.com/t5/APIs-Integrations/This-hapikey-doesn-t-exist/m-p/491700/highlight/t...

curl --request POST \
--url 'https://api.hubapi.com/crm/v3/extensions/calling/APP_ID/settings?hapikey=eu1-HUBSPOT-API-KEY' \
--header 'accept: application/json' \
--header 'content-type: application/json' \
--data '{"name":"demo widget","url":"https://twilio.com","height":600,"width":400,"isReady":true}'

{"status":"error","message":"Writes to call settings data only accepted on api.hubspot.com","correlationId":"4f5044c7-113d-4d5a-87eb-fb134c4ab074"}%

0 Upvotes
dennisedson
Community Manager
@YaminiBisht,
I will provide updates I when I get them as I indicated in that thread.
Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
sduane
Solution
HubSpot Product Team

Hi everybody! This issue is now resovled.

I really appreciate you both dropping a note about the Calling Extensions API not working with an application owned by an EU1 portal.

There was actually a bug in this specific service, which is now resolved. Give this API another shot, you should be good to go!

Sorry for the trouble!

View solution in original post

Kamil_A
Member

Now, it works for me, Thank You!

YaminiBisht
Participant

The API is working for me as well. Thank you.