This hapikey doesn't exist

SOLVE
OSgt
Participant

Hi everybody !

 

I have a problem and I don't understand. I can't use my developper api key because when I use it I have the error 'this hapikey doesn't exist. 

Even if I try the example request (with my own app ID, I have event type on this app) . I tried to generate a new key but I have the same error. 

 

Capture d’écran de 2021-0.png

Thanks for help

0 Upvotes
1 Accepted solution

Accepted Solutions
dennisedson
Solution
Community Manager

@awful-apps , a fix has been deployed.  (This does not address the calling extension issue.)  Mind testing to see if your key works?

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content

View solution in original post

0 Upvotes
25 Replies 25
dennisedson
Community Manager

@OSgt 

This is a weird one.

What endpoint are you trying to hit and could you show us the uri format you are sending?  you can hash out the key

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
OSgt
Participant

Hi @dennisedson,

I use postman, I don't understand why I have this error, have you an idea ? Capture d’écran de 2021-0--.png

0 Upvotes
webdew
Top Contributor | Diamond Partner

Hi @OSgt ,

It should not happen but you can do one thing , try to regenerate the key and then use it .

Hope this helps!


If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards. 

OSgt
Participant

Hi @webdew ,

 

Thanks for the answer, but I have already tried it..

0 Upvotes
dennisedson
Community Manager

@OSgt , I am looking into this

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
awful-apps
Participant
0 Upvotes
dennisedson
Community Manager

@awful-apps ,

The team is working on resolving this issue.  If you send the portal id to me, I will attach it to the open ticket

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
OSgt
Participant

Hi @awful-apps,

 

Not yet, I have also contacted hubspot support via chatbot and a ticket has been open, I will tell you when I have a solution. 

0 Upvotes
awful-apps
Participant

Ok thank you, will be following this thread. It's business critical.

0 Upvotes
awful-apps
Participant

@dennisedson do you have an ETA on the fix?

0 Upvotes
dennisedson
Community Manager

I don't have a specific time.  I can say that it looks like the problem has been identified and a patch is working its way up to QA so I hope it will be soon.  When I have an update, I will update this thread.

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
awful-apps
Participant

@dennisedson is there are work around for the time being? From what I understand it means I cannot interact with any of the apps I create in a developer account via the API..

0 Upvotes
dennisedson
Community Manager

@awful-apps ,

It depends on what kind of app you are creating.  Most endpoints allow for oAuth (actually we prefer oAuth over api keys), but there are some where you need the developer api key to edit settings.

I have been nagging on a fix so hopefully we have something today.

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
KikeDiaz
Member

Same issue here. Another ticket I created has been merged with this one:

https://community.hubspot.com/t5/APIs-Integrations/quot-This-hapikey-is-not-valid-because-the-associ...

Waiting for that solution. Thanks.

0 Upvotes
KikeDiaz
Member

Sorry I mixed things up. What I'm unable to do is to test the API Key of my developer account. I already created one APP and it failed when atttempting:

https://api.hubapi.com/integrations/v1/<my  application id>/timeline/event-types?hapikey=<my hapikey>&userId=<my user id>

What am I missing?

0 Upvotes
dennisedson
Community Manager

Oh,  I understand now.

I believe you are experiencing the same issue as expressed here

I am going to merge this question with that one.  I am hoping for a resolution on this issue today

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
Kamil_A
Member

I think I'm facing similar issue with non existsing app but using calling extensions API described here:  https://community.hubspot.com/t5/APIs-Integrations/Unable-to-create-Calling-API-settings/td-p/498311

 

I've also tried to call timeline API:

 

https://api.hubapi.com/integrations/v1/352688/timeline/event-types?hapikey=DEV_HUB_ID

 

 And I'm receiving error: 

 

{"status":"error","message":"This hapikey is not valid because the associated hub (24877413) is nonexistent.","correlationId":"ba689ac8-7a7a-4b28-8200-ec044a7598e7"}

 

Note: `24877413` is not my user ID.. 

0 Upvotes
dennisedson
Community Manager

Just a heads up that I have been informed that a fix is almost ready to be deployed.  Thank you for your patience.

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
ISandboxes
Member

I recently created my developer account. I created an App that already installed in an account. Now I'm trying to access Timeline Events APIs (https://developers.hubspot.com/docs/api/crm/timeline) with my Developer API key and I receive this error "This hapikey is not valid because the associated hub xxxxxxx is nonexistent." being xxxxxx my actual developer account ID.

 

I get that error when I try to perform this call in Postman:

https://api.hubapi.com/crm/v3/timeline/<my app id>/event-templates?hapikey=<my Developer API key>

 

Why is my developer account ID a nonexistent hub? How can I solve this?

0 Upvotes
dennisedson
Community Manager

@ISandboxes 

This is related to this issue

I am merging your question with that thread

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content
0 Upvotes
awful-apps
Participant

Hello, any word on the fix?

0 Upvotes
dennisedson
Solution
Community Manager

@awful-apps , a fix has been deployed.  (This does not address the calling extension issue.)  Mind testing to see if your key works?

Thanks,

Dennis




Check out our Community Developer Blog
where we feature our Community driven developer podcast and how to content

View solution in original post

0 Upvotes
OSgt
Participant

Hi @dennisedson,

 

Now, it works for me, thanks a lot !

KikeDiaz
Member

It now worked for me as well. Thanks

awful-apps
Participant

@dennisedson working for me also. thank for you for the updates, it's much appreciated