Welcome and Introductions

ML82
Participant

How can I change the url to not include en-us?

Hi! I have no idea what I am doing but I bought the domain and came to hubspot to set up the website.  I cannot figure out how to get it to be just the dot com. Not include /en-us after!  My default language is English-US, the language on my website is the same.  When I go to type in www.panhandleaginsurance.com it says it does not exist.  It only exists if I include \en-us.  The chat feature has been unable to help and they suggest I try here. I am not a web developer and was very proud I was able to connect the domain.  Please help!

6 Replies 6
Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

How can I change the url to not include en-us?

Hi @ML82 no worries, happy to help get it removed!

 

From Settings > Website > Domains & URLs click the "Language Settings" tab

 

With an English only website, there are two settings you can update:

 

1 - uncheck the toggle at the top to automatically create redirects. You don't need this if your website only exists in one language.

 

2 - next to your domain, where you have the language set, uncheck the toggle to include the prefix in the slug

 

It should look something roughly like this (with your domains of course):

 

Jnix284_0-1706210983664.png

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

ML82
Participant

How can I change the url to not include en-us?

ML82_0-1706211235784.png

This is exactly what mine looks like before you responded.  None of the toggles are "checked/selected".  Everything appears to be correct according to your picture.  It still isn't working. 

Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

How can I change the url to not include en-us?

Hi @ML82 there's one more place to check - can you open your home page and check the "Settings" where you add your internal page title, page title, meta description, etc. and see if there is any text in the content slug box?

 

Jnix284_0-1706217737048.png

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Upvotes
ML82
Participant

How can I change the url to not include en-us?

Hi Jennifer, see screen shots below:

ML82_0-1706221397715.png

 

ML82_1-1706221412128.png

 

0 Upvotes
Jnix284
Most Valuable Member | Elite Partner
Most Valuable Member | Elite Partner

How can I change the url to not include en-us?

Thanks @ML82, so here's what's happening - because your domain language is already set to English and you're not using the prefix slug in the URL, when you set the language on the individual page, HubSpot is interpreting that to override the default and adding it.

 

If you remove the language from the page, it will remove it from the URL and you should be all set.

 

You only need to set the language for individual pages if it differs from your default language when building a multi-language site.

 

Thanks for sharing this, I'll provide some feedback about the individual page setting to see if there's a way to make it more clear for new users.

 


If my reply answered your question please mark it as a solution to make it easier for others to find.



Jennifer Nixon - Delivery Lead at Aptitude 8

connect with Jen on Linkedin

0 Upvotes
ML82
Participant

How can I change the url to not include en-us?

Jennifer, you are a genius!!!  Thank you so much!!

That fixed my issue. 

0 Upvotes