Hubspot Extremely Slow

ninabachicha
Member

Hubspot is so slow it's practically unuseable half the time, the other half its just annoyingly slow but still works. I  have updated my computer and browser, and tried on different browsers and many different Wifi networks. Is there anything else I can do to get it to run normally? 

4 Replies 4
JessicaH
HubSpot Alumni

Hi @ninabachicha,

 

Thanks for reaching out.

 

One thing you can try is accessing your account in an incognito window and another browser. If the issue isn't present in incognito, then clearing your browser's cache & cookies (instructions here) to ensure that you are accessing the most recent version of your account may resolve the slowness you've been seeing.   

 

You can also try to disable some of your browser extensions to see if they are conflicting with HubSpot.

 

I hope this helps.

Take care!

Jess


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, in dem du deine Spracheinstellungen änderst !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
EmilGallant
Participant

 

We've been noticing the same thing, the beta version is especially slow and laggy. 

 

I haven't started analysing the javascript running on the pages but I can tell that the ajax calls are really interfering with the normal page actions.  It looks like they're trying to get clever and slowly render the page as it loads but that just locks everything up and makes the impression worse as you're basically stuck waiting for things to slowly get fetched from the server and wedged into the pages.

 

Using filters shows the problem clearly: every change to a filter causes some ajax in the background, even though you're presented with an "apply filter" button that does..... what exactly? 

 

It's averaging about 8 seconds to switch between Contact views.

 

About 10 seconds to switch the Deals view between list and tables.

 

Before someone suggests it's a browser, computer or network issue on my end. It's not.  HubSpot is slow on a Macbook Pro, a 24-core beast of a workstation, a 9th-gen i7 Windows machines,  in Firefox, Chrome, you name it.  It's slow on my office network, it's slow on my home fiber, it's slow over cellular. 

 

The site is slow and lags like crazy.  It's not cookies or browser extensions.

0 Upvotes
JessicaH
HubSpot Alumni

Hi @EmilGallant,

Could you confirm which beta you are using?
Are other members on your team experiencing the same behaviour?

Take care!

Jess


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, in dem du deine Spracheinstellungen änderst !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
EmilGallant
Participant

 

I'm not sure how to determine the beta version. It just says "beta" or "beta option" and none of the submenus seem to lead to a version number.

 

The slow speed is for everyone on my team, which spans 3 continents and 6 countries.

 

Open up Chrome, load the Contacts page, open a Dev Tools window and switch to the Performance tab.  Start a new recording and then apply a new filter condition to the Contacts view.  You'll see several multi-second  instances when either rendering or processing or fetching a network resource kill the responsiveness.

 

 

0 Upvotes