Email Verification Link Issue with Outlook

JSeinfeld
Member

Our users are having issues with the email verification link sent from Hubspot and the Outlook application.  I spent around 30 minutes on the phone with a Microsoft O365 engineer and he was able to pinpoint it to the way Hubspot is encoding the button (email verification).  We tested the link in OWA and we’re successful. We tested the link in a web browser, and it was successful.  When clicking the button in the email within Microsoft Outlook it fails.  The MS engineer said the way the button is being encoded and identified isn't getting picked up by the Outlook client.  I'd recommend either including an additional href= link instead of only nesting it in the button-a button-a-primary class or implementing a url shortener.  We are also thinking it could possibly be the length of the url causing issues since he mentioned links over 2k end up not getting implemented correctly within the Outlook application.   We do have workarounds in place but thought I’d inform you just in case others are having the issue in a corporate environment.  

0 Upvotes
1 Reply 1
TiphaineCuisset
Community Manager

Hi @JSeinfeld 

 

Thank you for reaching out. 

 

Do you remember what was happening? was there an error message, if so, do you have a screenshot somewhere? Was it happening to every user? 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !