Connected email channels don't work

SOLVE
KD0
Member

Hi,

 

I have recently connected new email addresses ("channels") to my HubSpot Inbox. 

But they don't work - the emails sent to these addresses don't land in the conversations inbox.

I have tried sending emails from my different personal email accounts (GMail, Outlook...) to the addresses connected to HubSpot, but not one email reaches the inbox.

 

I guess there's probably a simple setting to change that I have missed, but I can't figure it out. Can anyone help me please?

 

Thanks!

1 Accepted solution

Accepted Solutions
karstenkoehler
Solution
Most Valuable Member

Hi @KD0,

 

The email address highlighted in your screenshot is a fallback email address. Currently, this fallback email is used for sending emails (see checkbox on the left). The test email you just sent to yuor personal Gmail inbox probably came from this fallback email address.

 

As a next step, I'd try to remove to delete the email address you were trying to connect as a channel under Settings > Inbox > Inboxes and then re-connecting it, paying close attention to the instructions in each step.

 

Unfortunately, documentation on inboxes/conversations is not very detailed, otherwise it would be easier and faster to get to a solution.

 

Best regards!

 

 

Karsten Köhler
Freelance Digital Marketing Advisor

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

View solution in original post

12 Replies 12
karstenkoehler
Most Valuable Member

Hi @KD0,

 

Could you share screenshots of the connected inbox settings (Settings > Inbox > Inboxes) and the inbox itself where you are expecting to receive messages (Menu > Conversations > Inbox)? That would be a valuable first step for troubleshooting.

 

Best regards!

Karsten Köhler
Freelance Digital Marketing Advisor

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

KD0
Member

Hi @karstenkoehler yes no prob, I'll send some screenshots below. Thanks!

KD0_1-1614759624846.pngKD0_2-1614759645751.pngKD0_3-1614759697811.png

 

 

karstenkoehler
Most Valuable Member

Thanks @KD0! Those 23 conversations shown under "All conversations" / "Email" in the left sidebar are not the test emails that you've sent to the inbox email address, I'd assume?

Karsten Köhler
Freelance Digital Marketing Advisor

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

0 Upvotes
KD0
Member

@karstenkoehler No, they are all older conversations from February. All the test emails that I sent yesterday (2nd March) seem to not appear anywhere.

karstenkoehler
Most Valuable Member

Hi @KD0,

 

When you compose an email from your inbox (upper left of the screen), does that email go through?

 

Best regards!

Karsten Köhler
Freelance Digital Marketing Advisor

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

0 Upvotes
KD0
Member

@karstenkoehler I just tried to send an email from HubSpot to one of the connected addresses, support@because.eco, and nothing seems to happen. I also put in cc my own private email, and there the message went through as normal.

But I noticed something strange (see screenshot below). In the Trash folder I checked the notifications from yesterday about the new channels added to HubSpot. All these emails seem to contain the same information, and the same "strange" connecte email address, for example: hello-13@5912268.hubspot-inbox.com

Is that normal?

KD0_0-1614766264598.png

 

karstenkoehler
Most Valuable Member

Hi @KD0,

 

What I meant is sending an email from the inbox to your regular personal inbox, in Gmail or Outlook, for example. Does a message composed in your HubSpot inbox go through to a personal Gmail or Outlook inbox?

 

The hello-11@5912268.hubspot-inbox.com address looks like one of the fallback email addresses that HubSpot automatically creates – this deleted confirmation email should show your actual email address, not this hubspot-inbox.com one.

 

Have you tried disconnecting and reconnecting the inbox?

 

Best regards!

Karsten Köhler
Freelance Digital Marketing Advisor

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

0 Upvotes
KD0
Member

@karstenkoehler Yes I confirm, a message composed in my HubSpot inbox went through to my personal Gmail inbox.

Right, I see what you mean about the hello-11@5912268.hubspot-inbox.com address.
How do I change it? Or how do I disconnect and reconnect my inbox as you suggest?

KD0_0-1614767413488.png

 

 

0 Upvotes
karstenkoehler
Solution
Most Valuable Member

Hi @KD0,

 

The email address highlighted in your screenshot is a fallback email address. Currently, this fallback email is used for sending emails (see checkbox on the left). The test email you just sent to yuor personal Gmail inbox probably came from this fallback email address.

 

As a next step, I'd try to remove to delete the email address you were trying to connect as a channel under Settings > Inbox > Inboxes and then re-connecting it, paying close attention to the instructions in each step.

 

Unfortunately, documentation on inboxes/conversations is not very detailed, otherwise it would be easier and faster to get to a solution.

 

Best regards!

 

 

Karsten Köhler
Freelance Digital Marketing Advisor

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

View solution in original post

KD0
Member

Hello @karstenkoehler 

Sorry for not having replied sooner. Thanks for your advice, I still haven't managed to fix the issue because I'm waiting for some colleagues to assist, but I'll get back to you when it's done 🙂

JNathan5
Member

I am having a similar issue, sales team could not help me...

I connected my personal email with no issue, however when I went to connect my shared email, it would not work. I deleted my personal email per the instructions from the sales girl, and added my shared email box, I then went to add my personal email, and it defaults to the shared email box which is massively frustrating!! Any help would be insane! 

0 Upvotes
PamCotton
Community Manager

Hello @JNathan5, I see connected as personal the same email associated with your Community user. Currently, it is not possible to use a single email account as both your personal email and team email in HubSpot. 

I wanted to share this knowledge base here that may help with steps to connect your inbox.

 

Kindly,

Pam 

Você sabia que a Comunidade está disponível em outros idiomas?
Participe de conversas regionais, alterando suas configurações de idioma !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !