Facebook post did not let me select featured image

SOLVE
Highlighted
New Member

There are several images associated with a landing page, only one of which I would like to be the featured image. When posting a facebook link, it would not allow me to change which image I would prefer to be posted, although it did allow me to do so when posting to twitter:

Screen Shot 2017-06-12 at 11.14.54 AM.pngScreen Shot 2017-06-12 at 11.14.20 AM.png

1 Accepted solution

Accepted Solutions
Highlighted
Anonymous

Hey @lbriggs this can happen if Facebook has a cached version of the page you were trying to publish to this social media channel.

 

Facebook has a Debugger tool you can use so you can fetch new scrape information for the blog post or page you have published to this channel.

 

1) Go to https://developers.facebook.com/tools/debug/

2) Enter the URL for the blog post (or page) in question > click on Debug.

3) Next, review the information, and click on Scrape again so the tool fetches the newer, up-to-date information for the post/page.

4) You can scroll to the bottom to preview what will be shared the next time you publish the content to Facebook.

5) Now that you have debugged the content, publish it once more to Facebook.

 

fb-dev-debug.gif

 

...Let me know if this helps!

Reply
0 Upvotes
4 Replies 4
Highlighted
Anonymous

Hey @lbriggs this can happen if Facebook has a cached version of the page you were trying to publish to this social media channel.

 

Facebook has a Debugger tool you can use so you can fetch new scrape information for the blog post or page you have published to this channel.

 

1) Go to https://developers.facebook.com/tools/debug/

2) Enter the URL for the blog post (or page) in question > click on Debug.

3) Next, review the information, and click on Scrape again so the tool fetches the newer, up-to-date information for the post/page.

4) You can scroll to the bottom to preview what will be shared the next time you publish the content to Facebook.

5) Now that you have debugged the content, publish it once more to Facebook.

 

fb-dev-debug.gif

 

...Let me know if this helps!

Reply
0 Upvotes
Highlighted
Occasional Contributor

Hi all, I've had similar and related problems when sharing landing pages on Facebook, and it's mainly due to Facebook's new API change that limits link preview editing (due to the abuse publication of fake news recently).

 

I'm sharing some links below, but I think HubSpot should implement ASAP a "featured image" field in landing pages (as there is on blogs) so we can code the necessary open graph tags and point the image to that one, otherwise there's no apparent way to do it automatically without having to code each page individually.

 

News: https://developers.facebook.com/blog/post/2017/06/27/API-Change-Log-Modifying-Link-Previews/

 

Documentation for webmasters to incorporate the coding necessary for correct link preview information:

https://developers.facebook.com/docs/sharing/webmasters

Reply
0 Upvotes
Occasional Contributor

I add to this the facebook debugger for one of the links that didn't preview as expected, which states the open graph tag for image should be defined. But if Hubspot doesn't provide a featured image field for landing pages, how could we define this on a template basis? It seems we would need to code it individually on each template, but not everyone building pages has the knowledge to do it.

https://developers.facebook.com/tools/debug/sharing/?q=http%3A%2F%2Finsights.amplexor.com%2Fecs%2Fca...

Reply
0 Upvotes
Highlighted
New Contributor

I noticed this issue as well recently when Facebook changed their policy on being able to edit preview links July 18. https://www.facebook.com/business/help/247886969033572

 

 

They will also be preventing Graph API from working. It looks like we'll need to wait for an update.