Facebook Share does not work for First blog article only

SOLVE
Occasional Contributor | Platinum Partner

Hi,

 

On our blog we have problem with our first blog article (http://blog.inboundsys.com/migrating-your-website-from-cms-to-hubspot-cos), the facebook share button does not work, once we click on share button on above URL it shares the blog main page instead of that particular article. This works fine on all other blog articles, eg: http://blog.inboundsys.com/how-to-optimize-webpage-for-hubspot-cos. We are using same template/code for all articles.

an you please let me know what is causing this.

1 Accepted solution

Accepted Solutions
Highlighted
Occasional Contributor | Platinum Partner

Hi @aliciaw,

 

I just added one more blog content module below the current blog content module within template, then took social sharing code from new module and added this on old blog content module replacing old one. Suddenly it started working even there is no difference between two codes, suprised but it started working Smiley Happy

3 Replies 3
Highlighted
Top Contributor

Hi @JagadishINB, were you able to resolve this issue? If so, how? I did a test of your blog post because I am having a similar issue, but your share button seemed to work for me! 

Post_to_Facebook_and_Migrating_your_website_from_CMS_to_Hubspot_COS.png

Highlighted
Occasional Contributor | Platinum Partner

Hi @aliciaw,

 

I just added one more blog content module below the current blog content module within template, then took social sharing code from new module and added this on old blog content module replacing old one. Suddenly it started working even there is no difference between two codes, suprised but it started working Smiley Happy

Highlighted
Top Contributor

@JagadishINB - thanks for your reply, what a great idea! That seemed to help us get the source code right - possible that we deleted something or didn't copy the whole thing correctly in our first attempt. 

Reply
0 Upvotes