Editing a Facebook post after publication not possible?

New Contributor

We've published a Facebook post via HubSpot's Social Tools. We've discoverd some changes that we'd like to make to the post, but if I want to edit the post on Facebook directly, it let's me modify the content of the post, but when I save, it just reverts back to the original version without any error message.

Editing a post from within HubSpot after publication is also not possible, right?

Any ideas or pointers?

Reply
0 Upvotes
2 Replies 2
Community Manager

Hello @HubSpotOTron 

 

I was able to investigate more about this and If the post has been published, we won't be able to edit it from HubSpot anymore, but in Facebook, you should be able if the post was not "boosted".

 

Have you tried to edit in incognito? Also, some users mentioned that the new Facebook interface may cause that, switching back worked for them. But if you still have this behavior I would recommend reaching out to Facebook's technical support as they will be able to check what is happening on their end.

 

Kindly,

Pam


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!


Occasional Contributor | Diamond Partner

Hey there @HubSpotOTron !

 

I noticed that this question hasn't been solved so I decided to give my 2 sense. I've been using HubSpot's Social tools for the past few months now and have been able to find the ins and outs of the HubSpot platform.

 

Unfortunately, once you publish a post using the HubSpot publishing tool (whether it's for Twitter, LinkedIn, Facebook, or Instagram) you're unable to make changes to the posts. Any edits must be made within the social platform that the post has been shared on.

 

If you have any other questions about HubSpot's social tools, be sure to hit me up!

 

Best,

 

Eric