Gmail Integration Send Later button not working

New Member

We're having issues integrating Hubspot Sales with our Gmail accounts. They connect fine and everything seems to work with the tracking, but the "Send Later" button doesn't function properly. It isn't greyed out, it is orange like it should be, but when clicked on it says "Hubspot had trouble connecting to your inbox. Try Again"

 

When "Try Again" is clicked, a screen comes up asking to give Hubspot offline access. Once allow is clicked it goes into an endless loop between two screens: a Hubspot login and a "connecting your inbox now" screen that shows for only a split second before going back to the login.

 

We've tried this on multiple accounts across multiple computers. We've tried the app.getsidekick.com/restart link, uninstalling and reinstalling, etc. What else should we try to get this feature working?

Reply
0 Upvotes
3 Replies 3
Highlighted
Community Manager

Hi @clarke-inc, thanks for your question.

 

The core of the issue here seems to be that your inbox is not properly connected to the CRM. Indeed, the extension is requiring you to have a connected inbox in order to use the Send Later feature, and it looks as though there's been an issue with fully connecting said inbox. 

 

In looking at your account, it seems like you have two seperate email addresses that you've tried to connect, one @gmail.com and one @companyname.com. Currently, your Google Apps address seems to be having an issue connecting to the CRM. The error I'm seeing is relating to the software not being able to find your /All folder. To verify that access to this folder has been enabled, could you head to Gmail Settings > Labels, and ensure that "Show in IMAP" has been checked for All Mail, like so:

 

Settings   mpascaud hubspot.com   HubSpot Mail.png

 

Once this option is enabled, please try reconnecting your inbox by following these instructions.

 

Finally, I found that your email address is actually linked to several different portals; please ensure that you main/central portal has been properly selected in your settings, by following the instructions in this article: https://knowledge.hubspot.com/articles/kcs_article/account/how-to-connect-hubspot-sales-with-hubspot...

 

Once all of this has been done, go to app.getsidekick.com/restart once again, and try scheduling an email once more. let me know if this does not work, and I'll continue troubleshooting with you. Thanks for your patience!

 

May

Highlighted
New Member

Helped a lot thanks. Not sure why this seeting was off that being said. If it is the default behaviour when you have several email linked to your gmail, I would suggest to add this post to the common thread about hubspot sale activation with gmail as it was long to find. 

 

Thx

Reply
0 Upvotes
Highlighted
Community Manager

@mveillon Thanks for your feedback! This is not a default configuration - access to the Gmail /All folder is sometimes disabled with certain account configurations, but for the most part it is accessible by default. I'm glad that we were able to come to a solution here Smiley Happy -May

Reply
0 Upvotes