CRM editing leads upon import instead of creating new records

SOLVE
New Contributor

Hi, 

 

I have my CRM set to monitor the website for activity - which it does. Most of my business comes from B2B. We add the details to HS and start the contact process.

 

I decided to create a new page where B2B partners could add new clients but I seem to have a problem with creating new records. I would like a new record created if the email address is new but it seems to be editing records if any of the fields contact identical date - an example would be the notes section containg "TEST".

 

Is there any setting in the free CRM that I have missed that has caused this to happen or that I can reverse? 

 

Thanks

 

*Edit. The altenative would be for the HS forms to have more flexibility in terms of display and formatting

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Solution
Community Manager

Hi @Tim1969,

 

You can turn off cookie tracking on the form by following the steps outlined here.

 

Thanks,
Jenny


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!

View solution in original post

Reply
0 Upvotes
4 Replies 4
Community Manager

Hi @Tim1969,

 

Is the page that the partners are adding the clients on a landing page with a HubSpot form? If so, it sounds like the issue is that cookie tracking is enabled for the form, which would cause one record to update instead of creating new records for each new email address. 

 

HubSpot contacts are deduplicated based on email address so the functionality you are looking for can exist, we just need to edit the cookie settings of that form (assuming that is the set up you currently have). 


If I am misunderstanding, please let me know.

 

Thanks,
Jenny


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!
Reply
0 Upvotes
New Contributor

Hi,

 

Thanks for your help. It is a Hubspot form. I think I have now sorted it all out and even added some nice formatting. One issue that I have is probably cookie related. When I test the form on my laptop the form is alway prefilled with the last set of details. Is there a way to clear them or set the cookies differently?

Reply
0 Upvotes
Solution
Community Manager

Hi @Tim1969,

 

You can turn off cookie tracking on the form by following the steps outlined here.

 

Thanks,
Jenny


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!

View solution in original post

Reply
0 Upvotes
New Contributor

Many thanks - It's all sorted now

Reply
0 Upvotes