adding hyperlinks in emails not working properly

New Contributor

Hi Everyone,

 

We're using the free CRM tool and every time we add a hyperlink when composing an email message from the tool, it continues to hyperlink any text you type after a space. Is anyone else experiencing this?  It's little stuff like this that is making us wonder what else is broken. 

 

Expected behavior: 

1. Click insert hyperlink in email body

2. type in hyperlink, hit enter to insert

3. press space and continue to type non-hyperlinked text

 

Actual behavior:

1. Click insert hyperlink in email body

2. type in hyperlink, hit enter to insert

3. pressing space and continuing to type just extend the hyperlink to all new text.

 

On latest chrome in two separate Win 10 PCs. 

Reply
0 Upvotes
4 Replies 4
Highlighted
HubSpot Product Team

Hey @asoyfer does this apply, when you select a word/line of text to hyperlink?

Reply
0 Upvotes
Highlighted
Anonymous

Hey @asoyfer, to add the above this is how the HTML formatting works in most text editors. I'd advise highlight the text you want to hyperlink, so you can specify exactly what you want to be wrapped in the link 

Reply
0 Upvotes
Highlighted
New Contributor

@Anonymous thanks for your reply. Yes, that is how it should work but if you see the part about what is actually happening, that is most definitely a bug. Please try to reproduce it for yourself. 

 

1. In the compose email window off a contact type some text then some text that you want to hyperlink, highlight that text and click the little hyperlink button next to font formatting, insert a link, click enter (the text should now be blue) then hit space and start typing. Is that new text also blue and hyperlinked? That's what's happening to me and is not right. 

Reply
0 Upvotes
Highlighted
New Contributor

hi @roisinkirby, thanks for your quick reply. Yup, that's exactly what I'm doing. Type out some text, then select it to add a link, click the link button, insert the link, it turns blue, hit space and everything I type is still blue and part of the link.

Reply
0 Upvotes