Meeting URL not working

Highlighted
Regular Contributor

I go to SETTINGS > SALES > MEETINGS and request to link Google calendar. It says HURRAH! CONNECTED yet doesn't advance to the next screen where you set up the calendar. If you schedule a meeting from a contact, the meeting invite is sent and it synchrosise with the calander. What's not working is the meetings.hubspot.com/name URL

 

I've logged out of both G-calendar and HubSpot and restarted the computer and logged back in again and the problem persists. Using Chrome.

 

Frustrated as it appears the calendar is connected - it's just when you go back to SETTINGS > SALES > MEETINGS it always invites you to connect google calendar and there's no way to get to the MEETINGS page with the three tabs: preferences, calendar integration, custom domains.

Reply
0 Upvotes
2 Replies 2
Highlighted
Occasional Contributor

The meeting url and settings are under:

Sales>Meetings

 

If you move the cursor over the area to the right of the link, the Edit button appears.  (It is odd behavior, no reason it shouldn't just be there all the time)

Reply
0 Upvotes
Highlighted
Regular Contributor

I've gone to SALES > MEETINGS and there is a big button saying CONNECT GOOGLE CALENDAR. When I select that, it connects the calendar though when I go back to SALES > MEETINGS it again invites to to CONNECT GOOGLE CALENDAR. I can't get past the CONNECT GOOGLE CALENDAR screen so there's no way I can even edit the MEETING URL.

Reply
0 Upvotes