Inserting text into a template-generated email breaks formatting in Outlook

New Contributor

Below, steps to reproduce a bug (?) I'm encountering in the free tools. Here are steps to reproduce:

 

1. Create a template.

 

2. In Gmail (I'm using Chrome), click compose.

(Form for new email appears.)

 

3. At the bottom of the new message window, click on the small triangle to view the "more options" menu.

(drop down list appears.)

 

4. confirm that "Plain text mode" is not checked.

 

5. Click on the "Recipients" field and enter an address (for testing, I just sent it to myself.)

 

6. Click on templates.

(Pop-up appears listing available templates.)

 

7. Double-click on a particular template.

(Pop-up auto-closes, the new message subject line and email body now have the text from the template.)

 

8. In the body of the email, insert cursor within a paragraph of text.

 

9.Type additional text.

 

10. Repeat steps 8 & 9 elsewhere in the email.

 

11. Click send.

 

12. Viewing the email in Gmail on Chrome, the message appears correctly formatted.

 

13. Viewing email on iPhone native email app, the message appears correctly formatted.

 

14. Viewing the email in Outlook (Outlook 2010 v14.0.7184.5000, 32-bit) on PC (Windows 7 Professional) there are are line breaks before and after every portion of text inserted in steps 8-10. That's the bug.

 

Note that, when viewing the email in Outlook and then (via ALT + H ("Message" menu) then ALT + A ("Actions") then ALT + V ("view in browser")) viewing the email in Internet Explorer, every instance of text inserted in steps 8-10 is preceded by and followed by ​ (Unicode decimal/html: 226/â  8364/€ 8249/&lsaquo). These characters are not visible when viewing the same file in Chrome.

 

Not a technical guy, but I'm guessing the problem is related to templates being encoded in ISO-8859 instead of UTF-8.

 

Screen shots (sorry if these display really small, I can repost with larger versions):

 

Screen shot - Internet Explorer display of HTML of HubSpot template-generated email with insertions.JPGAs seen in IEScreen shot - HubSpot template-created email with inserted text as it appears in Outlook.JPGAs seen in OutlookScreen shot - HubSpot template-created email with inserted text as it appears in Gmail on Chrome.JPGAs seen in Chrome

 

 

 

Reply
0 Upvotes
3 Replies 3
Community Manager

Hi @Hersh thanks for your post, and an additional thank you for all of this additional information. I can see what youre referring to here, and I'd like to do what I can to reproduce these issues on my end. If I need any more information I'll let you know, and otherwise I'll keep you posted on any further updates here. 

Reply
0 Upvotes
Highlighted
New Contributor

Sure thing, happy to answer any additional questions etc. via email/phone/whetever.

Community Manager

Would you be able to send me a private message through my profile with a link to the template you created? This way we can do some further testing. 

 

Thanks!

Reply
0 Upvotes