Hubspot design error: Meetings Link Time Display for prospects

SOLVE
LauraPD
Member

We are based in London (GMT+1) our meeting links can be booked from 8 am to 6 pm. 

 

For customers/prospects in the USA using our meeting links, they see times in a 24-hour clock. Those in East Coast (GMT-4) see 03:00 through 13:00 and in West Coast (GMT-7) 12:00 through 10:00, and it's not clear the times they are looking at are displaying as a 24-hour clock. 

 

They often select 04:00 thinking this is pm and then receive an email confirmation for 04:00 am. 

 

Does anyone else have this issue? Can we change the time display to show the am/pm?

1 Accepted solution

Accepted Solutions
hendrikvi
Solution
Participant

Hi,

 

might be late to the party, but maybe it helps someone else as I was experimenting myself with the scheduling tool (and the shown time) and I noticed that there are 2 options. (you find them today in meetings -> settings -> configuration) 

 

1) Defaulted seems the option of "Use visitor's browser settings". I was able to test it as my Chrome Browser is set to American English and my Edge Browser is set to German. One showed am/pm the other the 24-hour clock.

 

2) When you chose a language (the Scheduler will then always be shown in that language), you can then chose a date/number format (according to a country - seems a little odd).

 

So, @LauraPD  I think you would probably need to chose "English" as language and then "United Kingdom". If this does not work, go with another country that offers the 24 hour clock.

 

Best.

View solution in original post

5 Replies 5
jennysowyrda
Community Manager

Hi @LauraPD,

 

You can edit the date and time format under the "configuration" settings within your meetings link. 

 

Thank you,

Jenny

0 Upvotes
LauraPD
Member

Hi Jenny, 

 

Thank you for your reply. 

 

I can only change it to a country, not 24-hour or am/pm format? Is there a way I can change it to display as 04:00 am and 04:00 pm rather than 04:00 and 16:00?

 

Many thanks for your help.

Laura

0 Upvotes
jennysowyrda
Community Manager

Hi @LauraPD,

 

I can confirm that changing the country from the configuration screen does change the appearance of the time from 12 to 24 hours. If you would like for the time to show in am/pm, you can select United States from the list.

 

Date and number format: United KingdomDate and number format: United KingdomDate and number format: United StatesDate and number format: United States

 

Thank you,
Jenny

0 Upvotes
hendrikvi
Solution
Participant

Hi,

 

might be late to the party, but maybe it helps someone else as I was experimenting myself with the scheduling tool (and the shown time) and I noticed that there are 2 options. (you find them today in meetings -> settings -> configuration) 

 

1) Defaulted seems the option of "Use visitor's browser settings". I was able to test it as my Chrome Browser is set to American English and my Edge Browser is set to German. One showed am/pm the other the 24-hour clock.

 

2) When you chose a language (the Scheduler will then always be shown in that language), you can then chose a date/number format (according to a country - seems a little odd).

 

So, @LauraPD  I think you would probably need to chose "English" as language and then "United Kingdom". If this does not work, go with another country that offers the 24 hour clock.

 

Best.

View solution in original post

jdelope
Participant

Hello, I have the same problem but the solution explained here doesn´t fit our case. We have a meeting in our Web and everyone from Latam to Asia could book, we cannot previously know who is going to book and present a specific calendar. The problem is Latam users see our agenda ranging from 3h to 14h in the 24-hours format and they select 3am or 4am of their time zone, since it´s the first free hours they see and think it´s pm.

Is there any option to make a better UX by changing the meeting time format from 24h to 12h am/pm when you choose the "User´s visitor browser setting" in the meeting configuration?

Best

0 Upvotes