Sales Hub Tools

AHaider3
Member

Error in Workflows

SOLVE

Hi,

 

Could someone please help me troubleshoot the following error occurring in almost all of the workflows I am creating,

 

"The property couldn't be set because the company isn't associated with any target records."

AHaider3_0-1643960607804.png

 

 

 

0 Upvotes
1 Accepted solution
karstenkoehler
Solution
Hall of Famer | Partner
Hall of Famer | Partner

Error in Workflows

SOLVE

Hi @AHaider3,

 

It looks like you're working a company-based workflow which has an action to update the property value of an associated record.

 

Here's an example of such a workflow: Enroll all companies where Name is known, copy company Name into contact property Company name field of all associated contacts.

 

HubSpot will throw an error if it can't find any associated contacts associated with the company. If there isn't anything to update, how can it be updated?

 

I'd recommend checking whether the actions in your workflow related to associated objects are correct. If they are, there is probably an issue of association between your company and contact (or other) records.

 

If you're unsure how to further troubleshoot this, feel free to share a screenshot. Alternatively, if you have workflows, you also have access to HubSpot support which you could contact through the purple help widget in the bottom right corner of the HubSpot app.

 

Best regards

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

View solution in original post

1 Reply 1
karstenkoehler
Solution
Hall of Famer | Partner
Hall of Famer | Partner

Error in Workflows

SOLVE

Hi @AHaider3,

 

It looks like you're working a company-based workflow which has an action to update the property value of an associated record.

 

Here's an example of such a workflow: Enroll all companies where Name is known, copy company Name into contact property Company name field of all associated contacts.

 

HubSpot will throw an error if it can't find any associated contacts associated with the company. If there isn't anything to update, how can it be updated?

 

I'd recommend checking whether the actions in your workflow related to associated objects are correct. If they are, there is probably an issue of association between your company and contact (or other) records.

 

If you're unsure how to further troubleshoot this, feel free to share a screenshot. Alternatively, if you have workflows, you also have access to HubSpot support which you could contact through the purple help widget in the bottom right corner of the HubSpot app.

 

Best regards

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.