Delayed chat notifications in Android app

Occasional Contributor

I've tried all the different power saving settings on two phones and still it's the same: if the phone has not been active for a while, we receive a new chat notification after 20-30 minutes. 

 

Of course the chatting customer is far away by that time.

 

Please find the below example. I believe the notification came up only because I have woken up the phone.

 

 

 

hubspot_chat1.PNG7:20hubspot_chat_notification.PNG7:43

Reply
0 Upvotes
6 Replies 6
Community Manager

Hi @bartosh,

 

Can you please confirm you have the most up to date version of the app? 

 

Can you share what phone you are working on, whether you are experiencing the issue on other phones, as well as if the issue persists across different internet connections (wifi, mobile, etc.)?

 

Thanks,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Hubspot app version 2.0.561

Samsung Galaxy J7 SM-J730F Android 8.1.0

 

Same (or even worse) behaviour on Sony Xperia, Android as well.

Most of the time we are on wifi.

 

Best guess is that this is Doze-related. The notification almost always pops-up as soon as you touch the phone. But we have switched off what we could with this regard and it is still the same.

Reply
0 Upvotes
Community Manager

Thanks @bartosh,

 

Do you mind sending along a screenshot of your settings in your phone and in your app preferences? I want to partner with the team regarding this matter once I have this information. 

 

For how to access these settings, I wanted to share this resource.

 

Thank you,
Jenny

 


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

I'm using a Polish version of Android so the screenshots would not be much of a help.

But I just went onto (will try to reverse translate Polish menus to English):

Settings/Applications/.../Special Access/Optimize Battery Usage

 

Hubspot was not on the Unoptimized Applications list. I've just added it and will let you know if it helps.

Highlighted
Occasional Contributor

I've just noticed that on our other phone this energy saving option is disabled. But we are still experiencing huge delays.

 

The phone model is Sony F8331, android 8.0.0

Reply
0 Upvotes
Community Manager

Thanks @bartosh,

 

If you can send along the screenshots of the settings on your phone, with the doze mode disabled, as well as specific examples of the delays on that phon, that would be great! I am going to partner with the team on this matter and want to ensure I have as much information as possible. 

 

Thank you,
Jenny


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes