Chat to appear only on desktop devices

SOLVE
Highlighted
New Contributor

Can I set up the chat to only appear when the user is connecting on a desktop devide? Thanks

1 Accepted solution

Accepted Solutions
Highlighted
Community Thought Leader | Diamond Partner

Hi @Kolotrip 

 

It appears it is still not possible to target desktop devices only with messages/chat.

 

This a shame. I hope it comes through as a feautre soon as it is possible with pop-up forms already. 

 

Hope this helps.

Phil Vallender | Inbound marketing for B2B technology companies
Reply
0 Upvotes
3 Replies 3
Highlighted
Community Thought Leader | Diamond Partner

Hi @Kolotrip 

 

It appears it is still not possible to target desktop devices only with messages/chat.

 

This a shame. I hope it comes through as a feautre soon as it is possible with pop-up forms already. 

 

Hope this helps.

Phil Vallender | Inbound marketing for B2B technology companies
Reply
0 Upvotes
Highlighted
HubSpot Product Team

Hi - Just to add some details here you can have the chat widget only display on Desktop and not mobile devices like pop-up forms does today. 

 

In the display option section, customize the chat widget's behavior on desktops or small screen sizes:

  • Desktop: clear the Pop open the welcome message as a prompt checkbox if you do not want the welcome message to display by default.
  • Mobile: clear the Pop open the welcome message as a prompt checkbox if you do not want the welcome message to display by default on smalls screens. Clear the Show chat icon on small screen sizes checkbox if you don't want the chat icon to to display on small screens.

For bots- the options are the same but can be found within the welcome message settings. click the Welcome message step. In the Welcome message panel that slides in on the right, edit your welcome message text and settings:

  • Enter text for a welcome message.
  • On the Desktop tab, clear the Pop open the welcome message as a prompt checkbox if you do not want the welcome message to display by default.
  • On the Mobile tab, clear the Pop open the welcome message as a prompt checkbox if you do not want the welcome message to display by default on smalls screens. Clear the Show chat icon on small screen sizes checkbox if you don't want the chat icon to to display on small screens.
  • Click Save.

Screen Shot 2019-05-02 at 12.23.54 PM.png

Highlighted
New Member

Hey! Is there any way to do it now? Seems like there's no option to do it now Smiley Sad For some reason, my chat flow is not displayed on the mobile devices and the problem might be that "Show chat flow on small screen sizes" is active but there's no way to change it.

Screen Shot 2020-06-11 at 12.19.03.pngScreen Shot 2020-06-11 at 12.20.51.png

Reply
0 Upvotes