Email tracking not working?

SOLVE
HubSpotUser2020
Member

Hello all,
loving the ability to track when an email has been opened/read but it doesn't seem to work? Have sent out 10 test emails, many have been opened and replied to but under Notifications they still show as "Sent" only. Email tracking seems to work with Gmail recipients but not with any others, wondering if anyone else has experienced this and what if anything I can do to resolve it? Email tracking would be wonderful ability to have, if I can get it to work. Any and all replies most gratefully appreciated. 

0 Upvotes
1 Accepted solution

Accepted Solutions
sferreira
Solution
HubSpot Employee

Hi @HubSpotUser2020 , 

 

Thanks for reaching out to our Community! 

A couple of questions before digging into this: 

  1. are you sending emails through the HubSpot CRM?
  2. or directly via your inbox Gmail or Outlook, using the sales extension?

When you send an email via the CRM, or through your Gmail/Outlook, using the sales extension, and ticking the "track/log" button, when someone opens that email you should be notified. HubSpot embeds an invisible one-pixel image into the email message once it is sent. When your recipient views the email and the images load, you will receive a notification that the email has been opened.

Please note: 

If the recipient's email client doesn't allow the tracking pixel to load, HubSpot will not be able to track the email open. HubSpot tracking can be deactivated in the following situations:

 

  • The recipient formats their email in plain text. 
  • The recipient's email client doesn't automatically download images. 
  • The recipient's corporate filter strips away all images for incoming emails. 
  • The recipient's installed a firewall/Ad Block/Ad Blocker that blocks images to load

If the recipient has a very strict spam filter where they block any images or link tracking from loading in emails, your tracked email could be filtered as spam. 

View solution in original post

13 Replies 13
sferreira
Solution
HubSpot Employee

Hi @HubSpotUser2020 , 

 

Thanks for reaching out to our Community! 

A couple of questions before digging into this: 

  1. are you sending emails through the HubSpot CRM?
  2. or directly via your inbox Gmail or Outlook, using the sales extension?

When you send an email via the CRM, or through your Gmail/Outlook, using the sales extension, and ticking the "track/log" button, when someone opens that email you should be notified. HubSpot embeds an invisible one-pixel image into the email message once it is sent. When your recipient views the email and the images load, you will receive a notification that the email has been opened.

Please note: 

If the recipient's email client doesn't allow the tracking pixel to load, HubSpot will not be able to track the email open. HubSpot tracking can be deactivated in the following situations:

 

  • The recipient formats their email in plain text. 
  • The recipient's email client doesn't automatically download images. 
  • The recipient's corporate filter strips away all images for incoming emails. 
  • The recipient's installed a firewall/Ad Block/Ad Blocker that blocks images to load

If the recipient has a very strict spam filter where they block any images or link tracking from loading in emails, your tracked email could be filtered as spam. 

View solution in original post

HubSpotUser2020
Member

 

I have sent emails via HubSpot CRM and via Gmail and via Outlook (both desktop and web-based). Email tracking does not work at all, except for Gmail recipients. And so it seems that email clients are no longer allowing the tracking pixel to load and so email tracking by this method is no longer possible.

 

0 Upvotes
sferreira
HubSpot Employee

Thanks for getting back to me @HubSpotUser2020 

Could I ask you to send me 3 tests: one via CRM, one via Gmail with the extension enabled, one via Outlook with the extension enabled to sebastian.ferreira@outlook.com ?

 

I'd like then to double-check the tracking, thank you for your cooperation.

0 Upvotes
HubSpotUser2020
Member

Thanks for the explanation. It seems likely that the tracking images are not being allowed to load and so email opens can not be tracked. Perhaps it was easier to track email opens 5 years ago but now there are filters and clients that prevent it. Since email open tracking is no longer widely available I won't waste your time with test messages or similar since of course I need it to work with non-Hubspot recipient addresses and that seems an unlikely outcome. Thanks much for taking the time to explain and if I may (humbly) suggest, can you please skillshare this information with your Chat support team? I spent several hours with them and they tested this and that and the other, then I posted here and your reply gave me the answer in seconds. Just a thought, would help to free up your Chat team members to deal with other issues. 

aprasad25
Member

Hey!

 

I'm having a similar issue - but it's not tracking the email through Gmail - i've tested it with people who have lax email permissions too. When i send an email through the HUBSPOT crm - it logs / tracks it - but it doesn't work with the gmail extension. 

 

it was working last week and now it doesnt. 

0 Upvotes
TiphaineCuisset
Community Manager

Hi @aprasad25 

 

Thank you for reaching out. 

 

With a free subscription, clicks will not be tracked. However, the opens should be tracked. Could you confirm that the track box is checked when the email is being sent? (You can follow these steps here for that)

 

Is this happening with all your emails or some of them? 

 

HubSpot uses an invisible pixel to track the emails. If the recipient's email client doesn't allow the track pixel to load, HubSpot will not be able to track the email open. HubSpot tracking can be deactivated in the following situations:

  • The recipient formats their email in plain text. 
  • The recipient's email client doesn't automatically download images. 
  • The recipient's corporate filter strips away all images for incoming emails. 

Thank you

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
jesseingels
Member

I'm having the same problem, my tracking stopped shortly after 8am on Sept 15, 2020. I sent a test email this evening to a gmail account and opened it on a mobile device that downloaded the images in my signature (so presumably the pixel image downloaded too) but it's still not showing "opened" in my gmail inbox.  I only send from gmail and use the sales extension & it's been working the last several weeks just find until 3 days ago.

0 Upvotes
sferreira
HubSpot Employee

Hi @jesseingels , 

Have you checked that the "TRACK/LOG" boxes are ticked when you send that message? 
Could I ask you to send me a test email to sferreira@hubspot.com ?

0 Upvotes
jesseingels
Member

Hi @sferreira, Yes, both boxes are checked by default and I've just sent you an email.

0 Upvotes
sferreira
HubSpot Employee

Hi @jesseingels 

I confirm that the pixel is firing correctly, I successfully received and opened your email: 

 

sferreira_0-1600341440814.png

 

 

 

sferreira_1-1600341463767.png

 

 

Don't hesitate if you have any doubts, 

 

Best, 

Sebastian 

 

 

0 Upvotes
SeaShellDigital
Member

I am not seeing the TRACK/LOG option.hubspotemail.PNG

0 Upvotes
sferreira
HubSpot Employee

Hi @SeaShellDigital , when you write an email from the CRM, you automatically track/log that email, I was referencing the Track and Log options from the Sales Extension: https://knowledge.hubspot.com/connected-email/how-to-install-hubspot-sales

cpbrody59
Member

Same functional area, different problem: I'm using Gmail extension (corporate domain with gmail cloud service, I use theChrome browser for UI) and I've set my Hubspot to log but not track emails - years ago.  I also set the account global preference the same (log yes, track no).  Starting on 23-Oct with no user intervention - I am the sole superuser - tracking was enabled i both places.  Even more peculiar, very few emails are being tracked.  I have only ever filtered our own domain, and one full address, but the majority of external address aren't tracked, though a few random emails are.  Icing on the cake: I explicitly disabled tracking again this morning, started a chat with Hubspot, and within an hour my tracking was enabled again.  Looking back through activity history I see tracking residue intermittenly and for aonly a few emails popping up over the past 3 years.  Any ideas what might be going on, especially in the past month?  The Hubspot folks are non-responsive about any new releases ....

0 Upvotes