Original Source Only Identifying "Integration" As Source, I Want My UTM Parameters To Be Source

SOLVE
Myles
Participant

Currently, I have a natively built site with an ajax form. We use Zapier to connect our native form to Hubspot and pass over user information. When I navigate to the analytics portion of each individual contact, it breaks down their Original Source 1 as "Integration" and Original Source 2 as "ZAPIER". All these contacts are being acquired from paid ad campaigns and I have UTM's on all my links for tracking purposes. How can I get my Original Source to pull from my UTM parameters?

1 Accepted solution

Accepted Solutions
DanielAudio19
Solution
Key Advisor

Hi Myles,

What you need to do is create a property called: "utm_source" add as a "single line text" and then in your form add it into the form and make it hidden.

After this you will see in each from submission in Hubspot the UTM and you can also filter to see these sources.

Daniel Bleichman
Marketing | AudioCodes

Danielbleichman@gmail.com
Did my post help answer your query? Help the Community by marking it as a solution

View solution in original post

4 Replies 4
DanielAudio19
Solution
Key Advisor

Hi Myles,

What you need to do is create a property called: "utm_source" add as a "single line text" and then in your form add it into the form and make it hidden.

After this you will see in each from submission in Hubspot the UTM and you can also filter to see these sources.

Daniel Bleichman
Marketing | AudioCodes

Danielbleichman@gmail.com
Did my post help answer your query? Help the Community by marking it as a solution

View solution in original post

Myles
Participant

Thanks for the advice! I do have one more question, I'm using a natively built form and not a Hubspot form. Does this change anything?

 

Thank You!

0 Upvotes
DanielAudio19
Key Advisor

You still need to sync it with a Hubpsot form so I do not think it should make a difference.

Daniel Bleichman
Marketing | AudioCodes

Danielbleichman@gmail.com
Did my post help answer your query? Help the Community by marking it as a solution
MObeid
Member

Hi @Myles, we're experiencing a similiar issue with a non-HubSpot form. Did the solution of creating a property called: "utm_source" work for you?

 

Thanks!

0 Upvotes