Landing Page not showing performance results

SOLVE
cbung
Participant

I created our first Landing Page.  I have shared the URL link and it has been clicked on several times.  Within the Landing Page are additional links to click and those have all been clicked on as well but there is zero Performance showing up for the Landing Page.  How can I fix it so the performance results populate for this Landing Page? *Our account is a Starter plan.

0 Upvotes
1 Accepted solution

Accepted Solutions
karstenkoehler
Solution
Hall of Famer

Hi @cbung,

 

Analytics and metrics on the page dashboard and your website analytics tools will update every 20-30 minutes, see here. Could you check whether the page performance is still not reflecting the recent activity?

 

Best regards!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

View solution in original post

3 Replies 3
karstenkoehler
Solution
Hall of Famer

Hi @cbung,

 

Analytics and metrics on the page dashboard and your website analytics tools will update every 20-30 minutes, see here. Could you check whether the page performance is still not reflecting the recent activity?

 

Best regards!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

View solution in original post

cbung
Participant

Thank you.  Patience is all I needed 🙂

karstenkoehler
Hall of Famer

Hahaha, glad it worked out eventually, @cbung. Have a great day!

Karsten Köhler
Digital Marketer | HubSpot Freelancer | CRM Consultant

Beratungstermin mit Karsten vereinbaren


Did my post help answer your query? Help the community by marking it as a solution.

0 Upvotes