Hubspot for Woocommerce Plugin merges unrelated contacts

SOLVE
FF2
Participant

Hello,

I frequently create woocommerce orders on the frontend for new customers who order via telephone. What I do is:

 

  • I ensure being logged out on my website
  • I place the customers order entering his / her information (email, phone number, …) in my woocommerce frontend

Although all customer data is completely unique, the plugin frequently merges the new customer contact to an older one I have created a couple of days ago using the same method.

 

Analyzing this issue, I found out, that the contacts are merged due to "matching cookies".

 

How can I disable cookie matching contacts merges on a specific form / in general?

 

Thank you so much in advance!

0 Upvotes
1 Accepted solution

Accepted Solutions
webdew
Solution
Top Contributor | Diamond Partner

Hi @FF2 ,

This might be due to cookie matching on the browser. I'm not sure how you would turn that off in WooComerce but I could suggest a little trick! If you open a browser in incognito it holds no cookies whatsoever thus this would not happen - I'd suggest you reach out to WooComerce and ask how it would be possible to turn off cookie matching in this case and if not possible - you can use the incognito browser whenever filling out these orders manually.

Hope this helps!

If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards.

View solution in original post

3 Replies 3
sharonlicari
Community Manager

Hi @FF2 

 

Welcome to the Community!

 

I'd like to share these articles that explain this:

 

Collect Contact Information Without Disabling Cookie Tracking On Your Forms

Customize cookie tracking settings and privacy policy alert

 

I'll also invite a few experts to this conversation so they can share their thoughts

 

Hey @warrendavey @darynsmith any thoughts you can share with @FF2?

 

Thanks 

Sharon


¿Sabías que la Comunidad está disponible en Español?
¡Participa hoy en conversaciones en el idioma de tu preferencia,cambiando el idioma en tus configuraciones!

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


FF2
Participant

Thanks a lot for your answer! Problem ist, that the woocommerce forms are treated as "non hubspot" forms in the backend, which means, I unfortunally do not have the options you mentioned above 😞

0 Upvotes
webdew
Solution
Top Contributor | Diamond Partner

Hi @FF2 ,

This might be due to cookie matching on the browser. I'm not sure how you would turn that off in WooComerce but I could suggest a little trick! If you open a browser in incognito it holds no cookies whatsoever thus this would not happen - I'd suggest you reach out to WooComerce and ask how it would be possible to turn off cookie matching in this case and if not possible - you can use the incognito browser whenever filling out these orders manually.

Hope this helps!

If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards.

View solution in original post