HubSpot Free is in English but Calendar displays in German.

SOLVE
Occasional Contributor

Hi, HubSpot Community,

 

I'm evaluating HubSpot Free with three other co-workers from the same domain, in English. For some reason, my calendar is displayed in German https://ibb.co/cOcHnw. I can't seem to change it back to English.

 

One of us was using the German version of HubSpot but then switched to English. Can this have something to do with it? How to solve it?

Thanks in advance!

 

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
HubSpot Moderator

Hi @Error  As it turns out, there are two different settings for language. There is a portal setting for language, and a user setting for language. Find instructions on how to change both language settings here

 

If the portal and user language are both set to English, but you are still seeing the German day tags, reach into your user settings and toggle away from English to any other language, save, then come back to those settings and toggle back to English. That should clear up any lingering language discrepancies. 

 

Thank you,

Ed Justen


Did my post help answer your query? Help the Community by marking it as a solution
6 Replies 6
HubSpot Moderator

Hi @Error This looks like a caching error. Can you sign out of HubSpot, clear the browser cache, then sign back in to HubSpot and check further? Please let me know. 

 

Thank you,

Ed Justen 


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Occasional Contributor

Hello, Ed,

 

Thanks, tried it, didn't solve the issue.

Reply
0 Upvotes
HubSpot Moderator

Hi @Error I see to portals assigned to you email address. Can you forward the Hub ID of the portal being affected? 

 

Thank you,

Ed Justen


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes
Highlighted
Occasional Contributor

Hub ID: 4051280

Reply
0 Upvotes
HubSpot Moderator

Hi @Error  As it turns out, there are two different settings for language. There is a portal setting for language, and a user setting for language. Find instructions on how to change both language settings here

 

If the portal and user language are both set to English, but you are still seeing the German day tags, reach into your user settings and toggle away from English to any other language, save, then come back to those settings and toggle back to English. That should clear up any lingering language discrepancies. 

 

Thank you,

Ed Justen


Did my post help answer your query? Help the Community by marking it as a solution
Occasional Contributor

@edjusten

 

This has solved the issue! Thank you very much.

Reply
0 Upvotes