Unable to install HubSpot Sales Outlook Desktop Add-in in Parallels Desktop for Mac Virtual Machine

manuolito
Member

Hello,

 

I am unable to install the HubSpot Sales Outlook Desktop Add-in in my virtual machine using Parallels for Mac.

 

After successfully installing Microsoft Visual Studio Tools for Office (VSTO) it cannot install the WebView2 runtime and outputs the following error:

 

"Access to path 'C:/Users/.../AppaData/Local/Temp/MicrosoftEdgeWebView2Setup.exe' is denied"

 

I looked for the file and installed it. Try to install the add-in again and still the same error even if the runtime is already installed.

 

Environnement:

  • Windows 10 via Parallels Desktop for Mac (v16.5.1)
  • Outlook for Microsoft Office 2019
  • Email provider OVH

 

Thanks a lot for you help!

 

Below is the traceback of the error.

 

+-----------------------------------------------------+
| HubSpot for Outlook Installer |
| Build: Thu 06/10/2021 16:26:01.91 |
+-----------------------------------------------------+
Thursday, July 8, 2021 - 1:07:37 PM
INFO: Installed IE version: 11.1.21354.0
INFO: Initializing addin registry
INFO: Cleaning Office Wef Cache
INFO: CleanOnlineAppCache
INFO: Downloading VSTO Runtime
INFO: Looking for Vsto installation key: SOFTWARE\Microsoft\VSTO Runtime Setup\v4
INFO: Installing VSTO Runtime, mode: repair
INFO: Removing installer for VSTO Runtime
ERROR: Vsto runtime installation failed: VstoInstaller.Models.VstoInstallerException: Unable to install required Microsoft Visual Studio Tools for Office (VSTO)
at VstoInstaller.RepairUtils.RuntimeRepair.<InstallVstoRuntime>d__17.MoveNext()
INFO: Downloading WebView2 Runtime
INFO: Installing WebView2 Runtime, mode: default
INFO: Removing installer for WebView2 Runtime
ERROR: Add-in repair/install failed: VstoInstaller.Models.VstoInstallerException: Unable to install the WebView2 runtime
at VstoInstaller.RepairUtils.RuntimeRepair.<InstallWebView2Runtime>d__18.MoveNext()

0 Upvotes
15 Replies 15
TiphaineCuisset
Community Manager

Hi @manuolito 

 

Thank you for reaching out and apologies for the delay here. 

 

From what can be seen in our knowledge base here our Outlook desktop add-in cannot be installed on Mac. I'd recommend trying to install the Office 365 add in instead. 

 

Hope that helps.
Have a lovely day,
Tiphaine.


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


manuolito
Member

Hi @TiphaineCuisset,

 

Thank you for the reply.

 

I am actually installing the HubSpot Sales Outlook Desktop Add-in in a Windows 10 Virtual Machine through the software Parallels Desktop for Mac on a Mac machine. So I guess it should work since since it's a Windows 10 Virtual Machine..?

 

My email is hosted by OVH. So installing it through the 365 Add-in wouldn't work neither...

 

Thank you for your help!

0 Upvotes
TiphaineCuisset
Community Manager

Hi @manuolito 

 

Thank you for your reply

 

I see, thanks for the explanations. I'm unsure if that would work and couldnt find a similar case but I can see with the team. 

 

Before that, would you mind sending me a screenshot of the error? Also, can you clarify exactly the steps you're taking until you get the error?

When you talk about 'Microsoft Visual Studio Tools for Office (VSTO)' and "WebView2" are you actually talking about the actual HubSpot outlook plugin? It doesn't look like the steps listed here -can you try those and see what happens? 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


manuolito
Member

Hi @TiphaineCuisset,

 

Please find attached the screenshot of the steps I did for the error to appear.

 

When installing the add-on, it installs "Microsoft Visual Studio Tools for Office (VSTO)" as well as "WebView 2 Runtime" as shown in the screenshots.

 

I am looking forward to hearing from you.

 

Best regards

 

Install HubSpot Add-on Error Step 1.png

Install HubSpot Add-on Error Step 2.png

Install HubSpot Add-on Error Step 3.png

Install HubSpot Add-on Error Step 4.png

    

TiphaineCuisset
Community Manager

Hi @manuolito 

 

Thank you for your reply and the screenshots and added details. I'm going to reach out internally. Can you send me via DM the email address you're using for this? 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
TiphaineCuisset
Community Manager

Hi @manuolito 

 

Thank you for your patience. 

 

The team came back and confirmed this should work. This error hasn't come up before, so we're not entirely sure what the exact solution here would be, but the first step would most likely be to give the app permission to access that folder/file path. Could you try and run the HubSpot plug-in .exe file (should be hubspotforoutlook_setup.exe) as an admin - instructions here. We're hoping that should give the installer access to the file path.

 

Thank you

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
manuolito
Member

Hi @TiphaineCuisset,

 

Thank you for your feedback. I followed your instructions and ran the installer as the administrator withtout success. I still get the same access defined error.

 

Please find attached the screenshot of the permissions on the specific file.

 

Screenshot 2021-08-05 at 10.10.41.png

 

I ran the MicrosoftEdgeWebview2Setup.exe file and correctly installed it. I then re-ran the Hubspot installer and still the same error...

 

FYI, I am using Windows 10 on a macOS 11.2.3 (M1 chip) via the software Parallels. I tried the installer in a true Windows 10 machine and it works like a charm. So I guess there should be some conflicts with Parallels / Mac.

 

Thank you.

0 Upvotes
manuolito
Member

Hi @TiphaineCuisset,

 

Is the HubSpot Outlook Add-in supported with the the Windows 10 ARM? I am running Windows 10 through a Macbook Pro with the software Parallels.

 

Looking forward to hearing from you.

 

Best regards.

0 Upvotes
TiphaineCuisset
Community Manager

Hi @manuolito 

 

Sorry for the late reply here, the team is still looking at this - I've transfered your info to them and will update as soon as I know more!

 

Thank you for your patience, 

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
manuolito
Member

Hi @TiphaineCuisset,

 

Noted. Thank you.

 

Looking forward the feedback from the team.

 

Best.

0 Upvotes
TiphaineCuisset
Community Manager

Hi @manuolito 

 

Thank you for your patience. 

 

The team was unable to reproduce this using the same Parallels VM version and Windows 10.

If the permissions are correct for the %appdata% folder, and that screenshot seems to indicate they are, it is likely that there is security software preventing the launch of the installer out of the temp folder.

 

We do not support Windows 10 ARM

 

We recommend checking security software on the VM to see if it had prevented running the file as well as validating %appdata% and the temp folder have proper permissions.

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
manuolito
Member

Hi @TiphaineCuisset,

 

Thank you for your reply and tests operated by the team.

 

Which is really weird is that the add-on installs Microsoft Visual Studio Tools for Office (VSTO) (successful) before WebView2 runtime (unsuccessful) and that both executables are downloaded in the same %appdata% folder.

 

Why is that one can be installed and not the other whereas they share the same access rights?

 

Best.

0 Upvotes
TiphaineCuisset
Community Manager

Hi @manuolito 

 

Thank you for your reply

 

I've passed on your information to the team and we'll let you know once there is an answer.

 

Thank you

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
manuolito
Member

Hi @TiphaineCuisset,

 

Thank you. Also, find below the answer from the Parallels® team:

 

Since we have the same exact behavior in a Windows ARM virtual machine and a physical Windows ARM machine, it's clearly an issue with Windows ARM, and we presume that it must have something to do with Windows ARM built-in x86 emulation.
 
We have submitted feedback regarding this app to Microsoft, so feel free to upvote it, as it may result in Microsoft taking a look at it: https://aka.ms/AAdhqni
 
However, of course, unless the Hubspot team decides to support Windows ARM and thus take a serious look at this case, it isn't very likely to be resolved.
 
Best.
0 Upvotes
TiphaineCuisset
Community Manager

Hey @manuolito 

 

Thank you for that.

 

I have double checked with the team that confirmed again we do not support Windows ARM at this time so this wouldn't work if you have a ARM-based Windows. 

 

You can still however log emails to your inbox in HubSpot with the BCC and forwarding address by following the steps here.

 

Thank you for your time and patience on this

Best, 

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !