Tracked emails showing up on contact record but not deal

lisat2m
Top Contributor

We have tracked emails that are showing up on the contact and company record, but not the deal record. Why would this be happening since the contact, company and deal were all created at the same time.  The deal has 3 contacts associated with it; two from a partner and one contact is end-user. All emails addressed to end-user or CCing end-user do not show up in the activity. I found this info from HS:

 

"Emails logged from your inbox will automatically appear on the contact and associated company records, as well as the five most recent open deals associated with the contact."

 

Based on the above info, I believe all correspondence should show up on this deal record.

There's only one deal associated with this contact and company. The email was sent 3/14.

13 Replies 13
jennysowyrda
Community Manager

Hi @lisat2m

 

Are you sending your emails from within the CRM or from you connected inbox? 

 

If you can send along screenshots of the records in question (or links to the contact/deal records), that would be great!

 

Thank you,

Jenny

0 Upvotes
lisat2m
Top Contributor

Hi. We are sending using the Chrome extension in Outlook. Is there a way I can send the screenshots in a private message. I did go back into some of the correspondence on the contact's record and edit to add to the deal, but it should have added to the deal automatically since the contact was associated with the deal from creation.

 

Thanks,

Lisa

0 Upvotes
jennysowyrda
Community Manager

Hi @lisat2m

 

You can initiate a private message by clicking the envelope icon in the top right hand corner, selecting "new message", and then typing in my username.

 

Thanks,
Jenny

0 Upvotes
lisat2m
Top Contributor

Not sure if you got my PM - it said I've reached the limit of PMs, but this is the first one I've tried to send. Anyhow, we have the same issue on another deal this morning. Email threads show up in the contact's record, but not the associated deal record. I can "force" the thread to appear on the deal record by going to contact record and editing, then adding the deal; however, this should be automatic when a contact is associated with a deal.

 

We've never had this issue in the past and now I have two deals that I know for sure logged emails are not showing on the deal record only on the contact's record. Also, the contacts have been associated with the deal since creation of the deal.

 

Thanks,

Lisa

0 Upvotes
jennysowyrda
Community Manager

Hi @lisat2m

 

I just tried direct messaging  you-let me know if you can access the message 🙂 

 

Thanks, 
Jenny

0 Upvotes
bonniehaleD13
Participant

Was this issue identified? I am having the same problem. Emails show up on the contact, but not on the specific deal. 

0 Upvotes
lisat2m
Top Contributor

No - I still don't know why this is happening

0 Upvotes
CT-Eko
Participant

I'm seeing this issue as well! @lisat2m could you please explain the steps you're taking to force the email threads to show up in the deal page? 

0 Upvotes
bonniehaleD13
Participant

Hi @CT-Eko! I have discovered a couple of steps you can take to associate an email with a deal.

1. Make sure you associate all deals to the contact you are emailing about those deals. You can do this from the contact’s page (which is easier when you have several deals associated with one person) or on the deal itself by adding them as a contact.

2. Go to an email associated with that contact and click edit. Scroll to the bottom and there will be an option to “Add a deal” to the email. You can add several if you need to. A deal will not show up if you have not associated it with the contact so be sure to add them beforehand. Once you’ve done this, you will see the email on every deal you added.
3. Some emails have been sent before you added the contact. You can retroactively add these emails into HubSpot by going to settings, going to the Email option, copying the forwarding email address generated by HubSpot and forwarding the email. It will auto associate to the contact and on most occasions deals with auto populate as well. I usually check to make sure it associates to the right deals.
4. On this same settings page, there is also a bcc email address that you can use, add it to all emails you want sent to HubSpot in the bcc and it will work similarly to the forwarding address.

I hope you find this helpful!

CT-Eko
Participant

@bonniehaleD13

Yes! That's great. Thanks!

0 Upvotes
SpiffyTraining
Participant

Is this not done automatically? Can it be done automatically? I don't want to have to associate all emails to a deal? What if I start a new thread - will that thread be tied? I'd assume no?


Thanks

CT-Eko
Participant

Emails to a contact will show up in a deal that the contact is associated with. I'm not sure what the behaviour is if a contact is involved in multiple deals though. You can manually assign a deal to an email thread from the contact's page if you require, but generally, it works automatically as long as you have the correct associations in place. 

0 Upvotes
GetAdmiralGary
Member

I'm having this same issue and I've been told HubSpot will look into it and get back with me, but surely it can't be that difficult. In reading previous threads, the previous default settings were that all activity would automatically be collected on a deal. Now it seems as though there's more work to go back in and then associate it with one or more deals the contact may be with. Very time-consuming. 

 

Here's what I'm currently doing, but still running into the issue of the Deal not pulling in email activity. 

1. Create Account

2. Add Contacts to Account

3. Create Deal 

4. Associate which contacts I want to be part of the deal

5. Then adding these Contacts to a Sequence that I've created which has a mix of emails and tasks. 

 

I'm not seeing email activity within the deal, unless I go back into the email that was sent on the person record, edit and then associate it with the specific deal. 

 

Any help? Is this the right or wrong process to take? 

0 Upvotes