Lost email tracking: Cannot uninstall and re-install Hubspot Sales for Outlook successfully

ErikaH
Member

Hello HubSpot community, I would be grateful for any assistance getting Hubspot for Sales Outlook (free version) working....

 

In short, I cannot seem to trouble-shoot the error message below and I don't see any Hubspot documentation to address it. I have lost all email integration capability and email tracking.  Loss of email tracking triggered my trouble-shooting efforts.  I think the error message below may have to do with uninstalling and reinstalling the products needed for set up (e.g.Hubspot Outlook for Sales, Hubspot Windows, Microsoft Visual Studio)  several times (as I plugged this error into Google search and this theory came up in a chat room).  But I can't seem to find a solution noted online if this is the issue so I am posting here and close to giving up. I'd think others Hubspot users would have this issue.  I should note that I have uninstalled and re-installed the needed products for set up a few times to address previous error messages prior to the one I had received see below.  I also uninstalled and reinstalled Microsoft Visual Studio per instructions in Hubspot documentation as part of the process.

 

Thanks in advance and see below for the error:

************** Exception Text **************
System. Runtime.InteropServices.COMException (0x800736B3): The referenced assembly is not installed on your system. (Exception from HRESULT: 0x800736B3)
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.GetManifests(TimeSpan timeout)
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()

0 Upvotes
3 Replies 3
jennysowyrda
Community Manager

Hi @ErikaH,

 

This seems to be a ClickOnce application/program issue which is causing the HubSpot Sales Outlook add-in to not be able to install on your Outlook.

 

To resolve this error, follow these steps:

  • Copy and paste C:\Users\%username%\AppData\Local into your Start menu and press Enter.
  • Go to Apps and delete the 2.0 folder.
  • Try the install again with the downloaded .exe file
  • If this doesn't resolve the error, return to C:\Users\%username%\AppData\Local and delete the following folders:
    • IsolatedStorage
    • assembly.
  • Once deleted, re-run the install.

 

Please let me know if this resolves the issue for you.

 

Thank you,
Jenny

0 Upvotes
ErikaH
Member

Hi Jenny, Thank you so much for the assistance. I am grateful for it. I tried the first route you suggested and it didn't work. I then started on the second route you suggested and I could not locate the isolated assembly folder/file. I looked under AppData/Local and Appdata/Local/Apps.  Can you be more specific where to find it? I also put below a copy of the Hubspot trouble-shooting log from the re-install for additional reference for route one.  I also tried to add and disable the add-in within Outlook to prompt things to be fixed as that had worked once on a different error in the past, and I am not sure if this is also linked to the problems I am having.  Adding and disabling the add-on didn't  work and I also put the error message that appears here at the end of this message. Finally, I am sending a copy via a picture of my installed programs list (after trying the first route) as I am seeing Microsoft Visual C++ 2010 x64 redistributable multple times as well as versions from 2005 and 2013. I flag them as I think they may be related to the Hubspot install and this possibly may be something else to troubleshoot and perhaps the files got there from my trying different ways to trouble shoot this problem.  Let me know if any of this context isn't clear as I am trying to help with added context that may be relavant. One last bit of context is that I have tried troubleshooting related to sidekick not installing correctly previously and I am not sure if there is an issue there too as the troubleshooting log says side-kick isn't installed. What I am trying to restore ultimately is email tracking and the Hubspot add-ins in my outlook toolbar that ask if I want to track email (and I can then select email tracking).  This is key functionality I am looking to restore. I also really value the Windows notifications related to the email tracking. Thank you again for your help.

 

Subject: hubspot troubleshooting 1st round 11/30

 

Friday, November 30, 2018 - 10:44:40 AM

INFO: Cleaning addin registry

INFO: Cleaning Office Wef Cache

INFO: CleanOnlineAppCache

INFO: Downloading VSTO Runtime

INFO: Looking for Vsto installation key: SOFTWARE\Microsoft\VSTO Runtime Setup\v4

INFO: Installing VSTO Runtime, mode: repair

INFO: Removing installer for VSTO Runtime

INFO: Uninstalling existing Add-Ins

INFO: Sidekick for Outlook is not installed

INFO: HubSpot Sales for Outlook is not installed

INFO: Downloading HubSpot for Outlook

INFO: Installing HubSpot for Outlook, mode: default

INFO: Removing installer for HubSpot for Outlook

INFO: Downloading HubSpot for Windows

INFO: Installing HubSpot for Windows, mode: default

INFO: Removing installer for HubSpot for Windows

INFO: Add-in repair/install succeeded.

 

After completing the install above and seeing that the problem wasn't fixed, I then went to Outlook/Managed add-ins, and then I disabled the sidekick add-in (there is a note in the dialog box that sidekick starts slowly too ), then I reenabled the add-in and then got the error message below.  Note that I did this process to troubleshoot previous error messages and it worked to get me back-up and running and email tracking was integrated within windows which it isn’t now.

 

Name: HubSpot Sales for Outlook

From: https://dl.getsidekick.com/outlook/vsto/Sidekick.vsto

 

************** Exception Text **************

System.Runtime.InteropServices.COMException (0x800736B3): The referenced assembly is not installed on your system. (Exception from HRESULT: 0x800736B3)

   at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.GetManifests(TimeSpan timeout)

   at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()HS 20181130_105434.jpg

 

0 Upvotes
jennysowyrda
Community Manager
0 Upvotes