Email forwarding (outlook) problem

InProjects
Member

Hello,

im just started to use HubspotCRM and finished my email integration (sync with outlook desktop application) and set required forwarding in Outlook. Then during testing i encountered an error, when forwarding brokes after first client response to our email. 

1 step - test client approaches us by email, outlook forwards email to CRM without a problem

2 step - we reply to test client via CRM, client get our response without a problem

3 step - test client replies to our reply

4 step - here is where problem starts. Outlook forwars his reply, however not as an email from our test client, but as an email from our own email box 

5 step - when we response on that message, our response goes to our CRM email box (in that case info@inprojects.hubspot-inbox.com). And we lose contact with our client because he cant get our email. 


Attaching screenshots maping this test of email communication. Please help, we cant find the source of problem. 

1.png2.png4.png3.png2020-02-22_00-25-23.png

 

Also what is that long, non function url that automatically generates on first email (at pictures 5, red framed)? Seems that CRM generates it and attach to email and client can see it. 

5.png

0 Upvotes
9 Replies 9
jennysowyrda
Community Manager

Hi @InProjects,

 

It seems like you are using the conversations tool, which includes a lot of the functionality you are looking for without you having to manually forward the emails. 

 

If you are looking to use your email address in association with the conversations tool, I would recommend that you stop forwarding emails from Outlook into HubSpot, as that will happen automatically. That is why you are seeing logging issues. 

 

The url you are seeing is the tracking pixel which is associated with all emails sent through HubSpot to give you information on when contacts open your emails.

 

If you are still stuck after following these steps, please let me know.

 

Thank you,
Jenny

0 Upvotes
InProjects
Member

Thanks for reply @jennysowyrda 

 

But if i understand correctly, if im going to use converstion tools without forwarding emails from outlook, then i can use only Team email.  That way new emails from clients, i have never previously spoke with, will go to my outlook email but not to converstion tool, since there is no way new incoming emails from outlook will get to CRM without forwarding.

 

Or do i miss something?

 

Best regards,
Alex

0 Upvotes
jennysowyrda
Community Manager

Hi @InProjects,

 

When you connect a shared inbox, incoming emails will be associated with HubSpot without you needing to forward them into the CRM - it will happen automatically.

 

Thank you,

Jenny

 

cc @sharonlicari@natsumimori 

0 Upvotes
InProjects
Member

Hi again @jennysowyrda 

 

Do you mean that i should ignore instructions that Hub Spot CRM gives me when im setting up my shared inbox? Because it literally asks me to "add your forwarding address". 2020-03-17_19-00-51.png

If i set up this forwarding im getting into the same problematic loop as I described.

If i dont set up my forwarding adress then none of incoming emails are uploaded into CRM. 

 

So it seems like there is no solution....

0 Upvotes
natsumimori
Community Manager

Hi @InProjects ,

 

You've connected a hosted email account following this documentation, is that correct? In that case, adding the hosted email as a forwarding address in your mail client is a correct step.

 

Is this behavior happenning with other contact as well? And if you disconnect the inbox and reconnect it again, does it solve the situation?

 

Natsumi

0 Upvotes
InProjects
Member

Hi @natsumimori,

 

yes i follow that instruction from A to Z. I tried deleting and creating new inboxes multiple times, testing it from varios emails always with the same result. It starts alright, we recieve an email, we response to it via conversations tool, sender gets our response, reply to it, we get that reply, but when we try to reply to that second email from client (his reply to our reply) conversations tool decides that sender is our own inbox and so we reply to ourselves not to our client (pictures 3 and 4).

0 Upvotes
jennysowyrda
Community Manager

Hi @InProjects,

 

Can you please share screenshots of how you set up the forwarding within Outlook? I want to ensure that the forwarding steps you set up are those outlined at the bottom of the article here.

 

Thank you,

Jenny

0 Upvotes
InProjects
Member

@jennysowyrda sure thing. Im so sorry it takes so long to figure out where problem is...

 

FIrst I set up a shared inbox and copy forwarding adress.

2020-03-24_21-26-09.png

I use an Outlook so i have to set up a Rule for forwarding messages (dont mind other rules, they aren't active and have no impact)

2020-03-24_21-33-22.png

I dont specify what messages should be forwarded = all messages are forwarded

2020-03-24_21-34-21.pnga

all messages are forwarded to "pople or public group"

2020-03-24_21-36-06.png

With no exeptions

2020-03-24_21-37-58.png

And then i just apply this rule and turn it ON. Nothing esle. 

2020-03-24_21-39-16.png

And then i get a test message from coolrobot, that everything is set up and working.

2020-03-24_21-40-42.png

0 Upvotes
jennysowyrda
Community Manager

Hi @InProjects

 

Thank you for sending the forwarding steps! I am going to partner with the team to ensure I have best next steps.

 

Do you mind direct messaging me an email header of an example email that you are sending which is not being properly captured by the conversations tool? 

 

Thank you,
Jenny

0 Upvotes