Bug - Incorrect Company associated with Contact in sidebar

Highlighted
Regular Contributor

Hello, 

 

Another bug.

Many of our Customers/ Companies (B2B) have the same domain as another Customer. [I.e. Starbucks (at 1st Street) & Starbucks (at Main Street).]

In the HubSpot CRM, the Contacts (people) are associated correctly with their corresponding Company site, however when looking at the Company associated with a Contact in the Outlook sidebar it often seems to display the wrong one. This is a problem for us for many reasons, but mostly when contacting a person through email, if you are using some of the Company information in the discussion, the information is wrong. E.g. different sites have different needs and products, but we might end up referring to something that is untrue.If someone were to contact us for Support, but the information shows that the site does not have an active Support contract, we might not give them Support.

 

Please let me know if a fix is in the works. We would like to add more people to our team, but I'm finding a lot of issues that might actually hamper productivity.

Reply
0 Upvotes
6 Replies 6
Highlighted
HubSpot Product Team

Hey @LauraA I beleive that this is the tool working as designed. HubSpot automatically associates contacts based on their email domain. 

 

For example if a contact at Starbucks 1st Street has the emaill address johnsmith@starbucks.com it will associated to whichever company has starbucks.com as the domain.

 

@jennysowyrda's post explains this association well:  https://community.hubspot.com/t5/Tips-Tricks-Best-Practices/Associating-Contacts-Companies-and-Deals...

 

If you want to associate based on a Company's franchise location what you will need to do in this case is disable association by domain (find out how here) and manually associate contacts with companies. 

 

 

Reply
0 Upvotes
Highlighted
Regular Contributor

I actually have this setting turned off, and it has been disabled since the beginning (because I knew that it was linking by domain).

The problem seems to be with the way the Outlook extension is grabbing the company info. In the HubSpot CRM, the Company is correct, but in the Outlook sidebar, it seems to grab whatever Company that has the same domain that HubSpot determines as the "1st" one.

Reply
0 Upvotes
Highlighted
HubSpot Product Team

Hey @LauraA this is the tool working as designed, it will pull in companies with corresponding domain. 

Reply
0 Upvotes
Highlighted
Regular Contributor

Hi,

 

I don't think so; this is not how it should behave; I have the "Automatically create and associate companies with contacts." turned "Off" in Settings and I have also “opted out” all the domains that are duplicated by our Customers.

 

For a clearer example, in HubSpot I have Randy associated with Starbucks in Belgium and Sally associated with Starbucks in Canada: in HubSpot they both show up correctly with their Company details correctly appearing as the Belgian and Canadian distinct information regarding those sites.

However, in the Outlook sidebar, Randy’s Company appears correctly, but Sally’s Company also appears as Belgium, and thus the information you have regarding Sally’s Company when sending an email is very incorrect. The problem seems to be with the way the Outlook extension is grabbing the company info. In the HubSpot CRM, the Company is correct, but in the Outlook sidebar, it seems to grab whatever Company that has the same domain that HubSpot determines as the "1st" one, even though I have turned that Off in the settings.

 

It is fairly easy to duplicate if you turn the setting Off and create 2 companies (or more) with 1 contact each. Every contact will appear with the same Company in the Outlook extension even if they are correctly associated in HubSpot.

Reply
0 Upvotes
Highlighted
HubSpot Product Team

Hey @LauraA could you send me a private message with some screenshots f these examples and I will forward to our support team for further troubleshooting.

Reply
0 Upvotes
Highlighted
Regular Contributor

Hello,

 

I sent you a message.

 

thank-you, Laura

Reply
0 Upvotes