Fix iOS app glitches (editing contacts)

SOLVE
Regular Contributor

I'm a relatively new user to HubSpot, and while I'm liking the software a lot so far (especially on PC), I'm currently experiencing a few glitches on the HubSpot iOS app that are hindering my experience a bit.

 

Hardware and software details

  • Experiencing this on both iPhone 5s and iPhone 6. Both are on iOS version 10.3.3.
  • HubSpot app version 2.20.4 on both phones.

Glitches

  1. When editing existing contacts, multi-line properties don't respond to the return button. I cannot write text on separate lines. However, if I input information into the multi-line property from the PC version of HubSpot, I can view those in the proper multi-line format on the contact's page on the app, but as soon as I click into the "Edit" menu, the multi-line entry becomes jumbled onto just one line.
  2. When editing existing contacts, properties that are low in the edit menu become covered by the keyboard. This only happens once I click into a text box (bringing up the iOS keyboard). While I can still enter text within these low down property text boxes, I have to do it blind (because it's covered by the keyboard). APPEARS TO BE FIXED IN 2.21.0
  3. Adding a new contact in the HubSpot app doesn't use the global default contact creation properties that I setup in the settings menu on the PC version of HubSpot. As a result, my users are shown an unfamiliar set of properties when creating a new contact on the app.

Thanks for your time. I really appreciate the responsiveness that I've seen from the HubSpot team in other threads across these forums!

1 Accepted solution

Accepted Solutions
Community Manager

Hi @bostorus, thanks for your patience! I wanted to let you know that we've pushed a new update to our tool, which should be available now in Google and Apple App stores that should resolve the multi-line text issue. Please let me know if you're still having trouble when swtiching between desktop and mobile. 

 

 

5 Replies 5
Highlighted
Top Contributor

I'm having the same issue as the first, screenshots attached for reference:

 

Before:

image_uploaded_from_ios_720.jpg

 

After

image_uploaded_from_ios_720-1.jpg

 

Community Manager

Hi @bostorus, thanks for sharing and providing such great detail.

@mwhite051 thank you for adding the screenshots, this really helps us to verify the issue you're experiencing.  

 

I'm working on my end to reproduce these behaviors, and I'm going to work with our team internally to see what would be the best way to resolve this moving forward. Once I have more information, I will provide an update on this thread.

 

If you're experiencing any other issues related to mobile, I would recommend creating a seperate post for each new issue so it can be addressed individually. Thank you! 

Regular Contributor

Thanks for the response. I've noticed that v2.21.0 appears to have fixed glitch #2. Hopefully glitch #1 will see a resolution sometime soon!

Reply
0 Upvotes
Community Manager

Hi @bostorus, thanks for your patience! I wanted to let you know that we've pushed a new update to our tool, which should be available now in Google and Apple App stores that should resolve the multi-line text issue. Please let me know if you're still having trouble when swtiching between desktop and mobile. 

 

 

Occasional Contributor

As an outside rep, My big issue in iOS glitches (on phone) is that I have a really hard time adding a new contact to a company. The delay is horrendous once I click on "Create Contact." I've given up trying to do it and now trying to create a work around where I just add my activity under the company and when I revisit the company from desktop.

Reply
0 Upvotes