Using Zapier to remove registrant from GoToWebinar through Hubspot

SOLVE
Regular Contributor

Hey Hubspot Community

 

So we are trying to set up a webinar process so we can control every aspect from Hubspot.

 

So far I have been able to make sure that we can send all emails from Hubspot by making sure that the unique login code is moved onto a Hubspot property.

 

The next challenge is to make sure that if/when a registrant clicks the cancellation button in our mails it is registered in both Salesforce AND GoToWebinar.

 

I have used a CTA in Hubspot for our cancellation button, and have made a workflow where a person clicks the CTA, has it's campaign status in Salesforce changed to "Cancelled" and have the word "cancelled" set in a Hubspot property.

 

The thought was that i then made a Zap in Zapier that says If the property in hubspot is changed - Then the registrant is removed from GoToWebinar.

 

Easy enough i thought, but i can't seem to get it to work.

 

Does anyone have experience with this solution or know another way of making this work?

 

Thanks in advance

JMort

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Solution
Regular Advisor | Platinum Partner

Hi @JMort 

I haven't worked with a GoToWebinar automation like this but I have had recent experience and issues with triggering Zapier via a Hubspot contact property change. My first piece of advice is to contact Zapier support to make sure your trigger is indeed still supported, in my case support for the property (last modified) that I was trying to trigger on had been removed. 

 

If the above doesn't work out, another way to trigger Zapier is via Webhooks.

 You create a Hubspot workflow that triggers when the contact property changes (allow re-enrollment) and this sends your contact data to a Zapier Webhook (which listens for data to be posted from your Hubspot workflow). Once your Hubspot workflow is triggering your Zapier webhook zap, you then continue with the GoToWebinar actions to remove the registrant.

 

 


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner

View solution in original post

6 Replies 6
Solution
Regular Advisor | Platinum Partner

Hi @JMort 

I haven't worked with a GoToWebinar automation like this but I have had recent experience and issues with triggering Zapier via a Hubspot contact property change. My first piece of advice is to contact Zapier support to make sure your trigger is indeed still supported, in my case support for the property (last modified) that I was trying to trigger on had been removed. 

 

If the above doesn't work out, another way to trigger Zapier is via Webhooks.

 You create a Hubspot workflow that triggers when the contact property changes (allow re-enrollment) and this sends your contact data to a Zapier Webhook (which listens for data to be posted from your Hubspot workflow). Once your Hubspot workflow is triggering your Zapier webhook zap, you then continue with the GoToWebinar actions to remove the registrant.

 

 


Did my post help answer your query? Help the Community by marking it as a solution.

Matthew Shepherd

An Inbound Growth Agency
Platinum HubSpot Partner

View solution in original post

Regular Contributor | Gold Partner

JMort: Hi

I am troubleshooting our integration with HubSpot and GoToWebinar. I am also using Zapier for this. I would like to send the unique join-URL to all prospects, but when I test the email, the link does not seem to work. Have you experienced this? 

Reply
0 Upvotes
Regular Contributor

Hey Nico

 

Yes, we went through a lot of trial and error.

 

Why don't you tell me some more details of your setup and I see if i can help you out?

 

JMort

Regular Contributor | Gold Partner

I created a custom property in HubSpot for the GoToWebinar join-URL. I added the join-URL to Zapier and it looks like the Zapier Zap is working. But when I send a confirmation mail from HubSpot with the custom property (join-URL from GoToWebinar) added to the mail as a personalisation token to people registered to the webinar (at this moment this is me and my colleague), the join-link is either not there, or only leads me to a 404-page.

 

I used this guide to setup the Zapier zap: https://www.inalign.com/blog/how-to-integrate-gotowebinar-with-hubspot#join-url

Have you experienced this before?

Reply
0 Upvotes
Regular Contributor

In your workflow, do you send the mail right away?

I'm asking since, depending on your Zapier account type, a delay of up to 15 minutes is necessary as the systems only synch once every 15 minutes.

 

Have you checked if the URL actually shows up in the property you created for it in Hubspot?

 

Did you, in part 2 and step 3 in your Zap flow, choose both email and the property in hubspot to be filled out?

 

These might be reasons why it fails.

 

Try them out if you haven't already and return to me if it doesn't work... we'll figure this out 🙂

Regular Contributor | Gold Partner

Hi JmMort

Thanks for getting back to me. I guess I have found the solution.

 

I figured that there was a 15 minute delay for the integration to work. I have decided I send a confirmation mail to the recipient right away without the link and a reminder mail a day before the webinar with the link. This seems to work.