Salesforce attendance statuses get changed by Hubspot


Hi there!


we have a problem with our Salesforce-Hubspot integration.

We do Webinars with GoToWebinar. After the webinar the attendance statuses (in the relevant Salesforce campaign) gets updated by a Hubspot workflow (we let them be set to "attended/no show").

The problem is, that for whatever reason the statuses always are set back automatically to "responded" and we don't know why.


Can anyone help in this case? 


Thanks, Isabel

2 Replies 2
Community Manager

Hi @ifischer,

Thanks for reaching out.
I want to tag in some subject matter experts to see if they have any suggestions.
Hi @trevorjones71 @StefaniUAT @Simplii, do you have any thoughts on this?


We are excited to announce that the Community will be launching a weekly newsletter on November 2, 2020!
Sign up today!

Hi @ifischer and thanks for the tag @JessicaH!


In order to answer this quesiton I would need to understand more about how the fields are set up in HubSpot and Salesforce and what your sync settings are in HubSpot.  A couple of possible explainations include:


  • A mismatch between the HubSpot property and the Salesforce Contact or Lead field.  If you are using a picklist, make sure these match exactly with no extra spaces, etc.  Better yet, use a picklist in the application that will control the field (I think you said HubSpot sets the property) and have the other side be a text field.  
  • Your integration settings could be set up to prefer the wrong system when resolving conflicts in sync.  If you want HubSpot to control the field, you need to make sure your integration settings allow HubSpot to win when there are differences in the sync.
  • You could have an issue with your workflow design.  For example, perhaps another workflow that sets the property to "responded" is triggering again/re-enrolling the contact when you don't want it to.

If you could provide some screen captures of your field/intergation settings it might be a bit easier to help.


Good luck!



If my post resolves your issue, please accept my post as a solution.