Issues setting Salesforce Selective Sync

Highlighted
New Contributor

Hi 

I am new to HubSpot and setting up the Selective Sync with HubSpot and Salesforce as I want to limit the leads, accounts, contacts & opps I import into HubSpot from Salesforce.

 

However, I am experiencing some issues with this, I just wondered if anyone could assist. When creating the new profile I have cloned my current profile (which has admin rights) and when on stage 1 of the selective sync, (create a new Salesforce Profile) when I edit the Profile's Standard Object Permissions to remove the Data Administration permissions from leads, accounts etc and go to save it throws up an error at the top (pls see below)

 

Has anyone else encountered this? To get round this I tick "Modify All Data" under Administrative Permissions but this then ticks the boxes I have unticked under Standard Object Permissions. Does anyone know how to resolve this issue?
thanks

Adrian

PS I did carry on past this stage (only by ticking the "Modify All Data" without realising at that time that it re-ticked the boxes) and then floundered on the HubSpot Integration Permissions, but I will save that for another post ;-)


hubspot issue.JPGError from Salesforce

Reply
0 Upvotes
1 Reply 1
Esteemed Advisor

Hi, @Adrian_Mills. Have you tried removing the 'Manage Auth. Providers' setting from the cloned profile? Those error messages look like requirements from other installed packages which were associated with the original profile, but not the cloned profile. You'd either need to add all those other ADP and MSO permissions (which are either available from the package, or via permission sets, I'm guessing), or remove the auth providers criteria from the clone.

[ETA: Cloning a profile won't clone any permission sets, as those sets are assigned only to users. Ensure the user on the cloned profile has the exact same permission sets as your admin user from the original profile.]


Brad Mampe, Salesforce Analyst, Fidelity
I'm probably wrong. I may not be right about that.
Reply
0 Upvotes