Collected forms not working

Highlighted
p7
New Member

Hi

 

I am using contact-form-7 on my wp site.

I enabled tracking code and it's working.

When I test submitting the form nothing happens.

https://patient7.com/osc/

Reply
0 Upvotes
1 Reply 1
HubSpot Moderator

Hi @p7     In order for Collected Forms to work correctly, the tracking code needs to be installed.   Looking at the page source on the page referenced above, I can see the tracking code installed however, using Chrome dev tools I'm not seeing that the tracking code is firing correctly (instructions here to check if the tracking code is installed and firing).

 

I noticed that the tracking code script is wrapped in another script tag: 

<!-- Google Tracking Code for https://www.patient7.com -->
(function(a,e,c,f,g,h,b,d){var k={ak:"868460038",cl:"7FzuCJel82wQhsyOngM",autoreplace:"855-636-7977"};a[c]=a[c]||function(){(a[c].q=a[c].q||[]).push(arguments)};a[g]||(a[g]=k.ak);b=e.createElement(h);b.async=1;b.src="//www.gstatic.com/wcm/loader.js";d=e.getElementsByTagName(h)[0];d.parentNode.insertBefore(b,d);a[f]=function(b,d,e){a[c](2,b,k,d,null,new Date,e)};a[f]()})(window,document,"_googWcmImpl","_googWcmGet","_googWcmAk","script");

<!-- Start of HubSpot Embed Code -->
<script type="text/javascript" id="hs-script-loader" async defer src="//js.hs-scripts.com/1986495.js"></script>
<!-- End of HubSpot Embed Code -->

So this may be th reason the tracking code is not firing.

 

Can you verify for me if you are using Google Tag Manager to embed your HubSpot tracking code? If not, con you confirm how you installed the tracking code?  If so, you may need to install the tracking code manually on that page.

 

Thank you,

Ed Justen


Did my post help answer your query? Help the Community by marking it as a solution
Reply
0 Upvotes