Cannot sync Deal Pipelines & Stages with Salesforce

SOLVE
elitchka_ftw
Member

Hello

 

We are currently testing syncing Deal properties between Hubspot and Salesforce.

 

In Salesforce we have 5 deal pipelines, each with specific stages.

I have created in Husbpot a custom property with those pipeline types as a dropdown list, and each pipeline type references the Salesforce Type ID, which has been taken from Salesforce.

 

Mapping
(custom Hubspot property)
pipeline_type (Dropdown select)

Record Type ID

RecordTypeId (Reference)

 

Also, in Hubspot, I've edited the deal stages to perfectly reflect what is in Salesforce.

For Deal Stages mapping - i get no warnings of errors - so this appears to look ok.

 

However, I'm not able to sync these two. Has anyone had such a problem? Do you know where the problem might be with this?

 

Thanks in advance

0 Upvotes
1 Accepted solution

Accepted Solutions
trevorjones71
Solution
Key Advisor

HI @elitchka_ftw and thanks for the tag @natsumimori!

 

The setup you describe sounds like it should work.  With that said, I wonder if you have tried setting the HubSpot properties for RecordType ID as Text Fields, rather than dropdowns and seeing if it would sync that way? 

 

If you are using a field strictly for integration purposes and it won't be set from HubSpot, best practice would be to let Salesforce contain the dropdown list and push text to HubSpot without restrictions.  That should eliminate the chance that a mismatch can prevent sync.

 

Beyond that, perhaps a screenshot of your HubSpot integration settings would be helpful to understand what else might be happening.

 

Hope this helps!

-Trevor

If my post resolves your issue, please accept my post as a solution.

View solution in original post

2 Replies 2
natsumimori
Community Manager

Hi @elitchka_ftw ,

 

Thanks for reaching out to the HubSpot Community.

@bradmin and @trevorjones71 , would you be able to share you advice for @elitchka_ftw ?

trevorjones71
Solution
Key Advisor

HI @elitchka_ftw and thanks for the tag @natsumimori!

 

The setup you describe sounds like it should work.  With that said, I wonder if you have tried setting the HubSpot properties for RecordType ID as Text Fields, rather than dropdowns and seeing if it would sync that way? 

 

If you are using a field strictly for integration purposes and it won't be set from HubSpot, best practice would be to let Salesforce contain the dropdown list and push text to HubSpot without restrictions.  That should eliminate the chance that a mismatch can prevent sync.

 

Beyond that, perhaps a screenshot of your HubSpot integration settings would be helpful to understand what else might be happening.

 

Hope this helps!

-Trevor

If my post resolves your issue, please accept my post as a solution.

View solution in original post