Weekly Email Workflow that doesn't trigger

SOLVE
nasreenfxa
Member

Hi I'm trying to setup a weekly workflow but it doesn't always trigger and when it triggers the first time it usually just sends the contacts to the delay until 4:30pm and then still doesn't send out any emails. I have a workflow set up for every day of the week and it worked the first week but I've had issues for all the following weeks (I'm on week 3) and today it didn't trigger at all. The list memberships are all set for re-enrollment I have the settings to go out at a specific time (that day between 9am-5pm) and I removed a goal because when I had a goal it removed the contact completely and didn't re-enroll but now it re-enrolls but doesn't send out the email anywhere in the steps that have the action to send email. Any help would be appreciated! Thanks!

Screen Shot 2020-07-22 at 4.39.34 PM.png

0 Upvotes
1 Accepted solution

Accepted Solutions
StefaniUAT
Solution
Key Advisor

@nasreenfxa,

Setting up the date centered property is quite easy and not as daunting as I think you are expecting. I think using the date centered property would be your best bet.

 

I would also suggest talking to support about your current workflow that it is not sending. Support should be able to go through the workflow history and get to the bottom of it!

View solution in original post

0 Upvotes
6 Replies 6
StefaniUAT
Key Advisor

Hi @nasreenfxa,

Please forgive me if I am misunderstanding the need. However, I have had a similar issue with this type of workflow. Can you confirm that the goals and suppression list are not stopping these from going out? Have you checked the history page to see what is stopping them from progressing to the next step (getting the email)?

 

For example, I had a similar workflow and had a suppression list for records that have not gone through an expected/instant workflow and met the suppression list criteria before reaching the proper workflows.

 

Also, what HubSpot plan do you currently have? Is there a reason you do day of the week instead of (days, hours, minutes) delays after enrollment?

 

Sorry to ask so many questions. I have not had a workflow error like that unless it is something completely unexpected.

nasreenfxa
Member

Hi @StefaniUAT ,
Thanks fo responding and I appreciate any help you can give.

I turned off goals because I noticed it didn't re-enroll contacts and that worked to re-enroll but then somehow it ignores the first send and moves all contacts to the 4:30 send and then doesn't send anything. These are my suppression settings:

Screen Shot 2020-07-23 at 9.26.16 AM.png
We have Enterprise. Not sure what you're asking regarding the reasoning for day of the week. I considered doing based off date but I need this email to go out weekly for the next 6 weeks so to avoid a long workflow of putting in each date I thought this way would be easier and then I could just turn it off after 6 weeks. But if it works better to just base it off the date then I can go that route too.

Thanks!

0 Upvotes
StefaniUAT
Solution
Key Advisor

@nasreenfxa,

Setting up the date centered property is quite easy and not as daunting as I think you are expecting. I think using the date centered property would be your best bet.

 

I would also suggest talking to support about your current workflow that it is not sending. Support should be able to go through the workflow history and get to the bottom of it!

View solution in original post

0 Upvotes
nasreenfxa
Member

I reached out to support and they are trying to figure out the issue now. Thanks for helping out!

nasreenfxa
Member

Just FYI...There is no solution at this point, support said they would work on it. Contacts are not being re-enrolled in the workflow and all the workarounds that I've tried are not working so hopefully they come up with a solution but as of now I'll have to figure out another way to send these out daily.

0 Upvotes
StefaniUAT
Key Advisor

@nasreenfxa I actually have a few more ideas to help. I can't promise any of them will work but could be worth a shot. Shoot me a message if you are interested.