Third Party Coockies

SOLVE
Highlighted
New Contributor

The use of mail tracking requires third party cookies to be enabled.  This allows all websites to place 3rd party cookies.  Is there a way to limit the placement of third party cookies to hubspot so that mail tracking still works?

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Solution
HubSpot Alumni

Hi @dfrankfurter,

 

Please try adding [*.]getsidekick.com to your exceptions. I think this one will definitely fix your issue. Once you have added the exception, visit app.getsidekick.com/restart to restart your Chrome extension.

 

Please let me know if that helps.

 

Rami 

View solution in original post

8 Replies 8
Highlighted
HubSpot Alumni

HI @dfrankfurter,

 

While it is recommended to enable cookies overall for optimal performance with HubSpot, you can take advantage of a setting in Google Chrome to block cookies while making an exception for certain domains. Here are the steps that I have gathered from a Google Chrome help document

 

- On your computer, open Google Chrome.


- At the top right, click the Settings icon and then Settings.


- At the bottom, click Show advanced settings.


- In the "Privacy" section, click Content settings.


- Under "Cookies," click Manage exceptions.


- Enter the site name you want to allow cookies for (HubSpot)


- To allow cookies from an entire domain, insert [*.] before the domain name. For example, [*.]hubspot.com. This creates an exception for all HubSpot cookies. 


- You can also put an IP address or a web address that doesn't begin with http.


- To the right of the site name, click the Down Arrow.


- Choose whether the site can set cookies. If you select Clear on exit, its cookies are deleted every time you close your browser.

 

Rami 

Reply
0 Upvotes
Highlighted
New Contributor

Hi @relabidin

Thanks for your response.  I had tried this, but it doesn't seem to work.  I am unable to siign in to the sales module.  I tried it again, but to no avail.  I don't know if all third party cookies need to be enabled or if there is another domain name needed in the exceptions.

David

Reply
0 Upvotes
Highlighted
HubSpot Alumni

Hi @dfrankfurter,

 

You can also add the domain api.hubapi.com to your whitelist. I recommend enabling third party cookies overall, though. 

 

Where are you trying to sign into? Your HubSpot portal in the browser? The Chrome extension? The Outlook plugin?

 

Rami 

Reply
0 Upvotes
Highlighted
New Contributor

Thanks again @relabidin for your response.

 

I am using Chrome, and trying to sign in to the Sales Tools of the Hubspot app.

 

Whitelisting [*.]hubapi does not fix the problem.

 

While I understand that allowing all third party cookies does the job, it allows unscrupulous site operators to place unwanted tracking and advertising cookies which are intrusive and can slow don browsing and be an entry spot for spyware. 

Reply
0 Upvotes
Solution
HubSpot Alumni

Hi @dfrankfurter,

 

Please try adding [*.]getsidekick.com to your exceptions. I think this one will definitely fix your issue. Once you have added the exception, visit app.getsidekick.com/restart to restart your Chrome extension.

 

Please let me know if that helps.

 

Rami 

View solution in original post

Highlighted
New Contributor

Thank you @relabidin.  This has workd nicely. 

Reply
0 Upvotes
Highlighted
New Contributor

I have the exact same problem. The solution URL here did not help my issue at all. So far only a generic opening to all 3rd parties gets me green light. Has the URL changed to set cookie exceptions?

Reply
0 Upvotes
Highlighted
Occasional Contributor

Ditto. Disabling "Block Third Party Cookies" works, but I'd prefer to not disable that and only whitelist what I'd need to. So far I have:

 

[*.]getsidekick.com
api.hubapi.com
[*.]hubspot.com
[*.]sidekickopen69.com
 
...But I still get the: Sorry. It looks like your browser settings are blocking HubSpot Sales.
To learn how to change your browser settings, please read this article. Then, come back here and reload Gmail.