Lists, Lead Scoring & Workflows

JamesTucker
Participant

Stop sending emails to new contacts in a date centred workflows

SOLVE

When I setup a date centred workflow to send previous customers a monthly email on the first day of every month using delay actions, customers who are enrolled at the beginning go through the workflow as expected. But, new contacts who meet the enrollment criteria skip the date delays (becasue they are in the past) but do not skip the email sends or other actions. This sends a new enrolled contact all of the emails sent previously at once and then they continue as normal. 

How can I set this up to only send the emails that are due to be sent after their date of enrollment.

0 Upvotes
1 Accepted solution
DAnaGuiloff
Solution
Contributor | Partner
Contributor | Partner

Stop sending emails to new contacts in a date centred workflows

SOLVE

Hi James,

 

For the date centered workflow, rather than adding the email directly in that workflow, instead create a separate one(s) with the email to be sent and enroll the contact from the date centered one.

 

So it would look something like this (very simplified)...

 

Workflow 1: Date Centered

Do next Action: X time before/after date property (whatever your delay is)

Enroll in Another Workflow: Send Email A (the email you want sent out)

Do next Action: Y time before/after date property (whatever your next delay is)

Enroll in Another Workflow: Send Email B (the next email you want sent out)

 

Workflow 2: Send Email A

No Triggers Set: Contacts are manually enrolled

Send Email: Automated Marketing Email A 

 

Workflow 3: Send Email B

No Triggers Set: Contacts are manually enrolled

Send Email: Automated Marketing Email B 

 

Your History on the date centered workflow would show in the event column, that enrollment was skipped because it would have executed in the past: 

Workflow History ErrorWorkflow History Error

*Don't forget to set re-enrollment if you plan on sending them through Workflows 2 or 3 again.

 

Hope that helps!

D'Ana

√ Did my post help answer your question? Pay it forward and help the Community by marking it as solution!

View solution in original post

0 Upvotes
2 Replies 2
DAnaGuiloff
Solution
Contributor | Partner
Contributor | Partner

Stop sending emails to new contacts in a date centred workflows

SOLVE

Hi James,

 

For the date centered workflow, rather than adding the email directly in that workflow, instead create a separate one(s) with the email to be sent and enroll the contact from the date centered one.

 

So it would look something like this (very simplified)...

 

Workflow 1: Date Centered

Do next Action: X time before/after date property (whatever your delay is)

Enroll in Another Workflow: Send Email A (the email you want sent out)

Do next Action: Y time before/after date property (whatever your next delay is)

Enroll in Another Workflow: Send Email B (the next email you want sent out)

 

Workflow 2: Send Email A

No Triggers Set: Contacts are manually enrolled

Send Email: Automated Marketing Email A 

 

Workflow 3: Send Email B

No Triggers Set: Contacts are manually enrolled

Send Email: Automated Marketing Email B 

 

Your History on the date centered workflow would show in the event column, that enrollment was skipped because it would have executed in the past: 

Workflow History ErrorWorkflow History Error

*Don't forget to set re-enrollment if you plan on sending them through Workflows 2 or 3 again.

 

Hope that helps!

D'Ana

√ Did my post help answer your question? Pay it forward and help the Community by marking it as solution!
0 Upvotes
JessicaH
HubSpot Alumni
HubSpot Alumni

Stop sending emails to new contacts in a date centred workflows

SOLVE

Hi @JamesTucker,

 

I'm going to tag some thoughtleaders to see if they have some input on this.

 

Hi @slogans @JemmaLegg @David_HubSnacks, do you have any suggestions?

 

Thanks!

Jess

 


Wusstest du, dass es auch eine DACH-Community gibt?
Nimm an regionalen Unterhaltungen teil, in dem du deine Spracheinstellungen änderst !


Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes