Lists, Lead Scoring & Workflows

nvawh
Member

Gender branch not reading gender property

Our gender property is a Hubspot created property. When people fill out our form on our website, they are automatically added into Hubpot as a contact. The gender branch in my automations are just pushing everyone through to 'None Met.' 

 

Any idea on how to fix this?Screenshot 2024-05-08 110055.png

0 Upvotes
5 Replies 5
Opveng
Member

Gender branch not reading gender property

Hey nvawh,

 

What kind of property is the gender field? Are we sure its not a text field? Because if it is than the workflow might be having difficulties in reading it. A drop-down of all options would be ideal here. Possible for you to share the branch conditions here? As that would help us better understand why it would be pushing it to the not-met branch.

0 Upvotes
nvawh
Member

Gender branch not reading gender property

It is a text field and I would love it if it were a dropdown, but its a Hubspot generated property that is used on 10,000 of our contacts. Is there any way to change this?

0 Upvotes
Opveng
Member

Gender branch not reading gender property

For filtering are you using the criteria 'contains any of' or 'contains
exactly'?
0 Upvotes
franksteiner79
Key Advisor

Gender branch not reading gender property

Hi @nvawh 

 

What is your enrolment trigger for the workflow? Are you asking for the gender on the form, and is the property mandatory?

 

If a contact has no value for the gender property they will end in the "not met" branch.

 

Frank

Found my comment helpful? Great! Please mark it as a solution to help other community users.


Frank Steiner

Marketeer | HubSpot Expert | CRM Consultant

InboundPro

Let's Talk About Your Project
0 Upvotes
nvawh
Member

Gender branch not reading gender property

The enrolment trigger for the workflow works correctly as they get all the way to the branch and then just go to the not met part. Gender on the form is mandatory 

0 Upvotes