Submit button on form not working

AEdwards2
Member

Hi there,

 

I have a form on a landing page. The "submit" button is clickable when I go to just the form, but when someone clicks on the "submit" button on the landing page the button isn't clickable so the form isn't submitting.

I looked at the code (I am not a coder!) and searched for "submit" and the only instances of "submit" are in the text confirming the form has been submitted. Could the button be 'missing' from the page, like it's showing up but it's not actually clickable? 

 

Ann

0 Upvotes
2 Replies 2
webdew
Top Contributor | Diamond Partner

Hi @AEdwards2 ,

Is this a HubSpot form?
Can you please share the link of the form here?
Also, if it is the HubSpot form, do one thing, remove and insert the submit once again and publish the form.

Hope this helps!


If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regard.

AEdwards2
Member

Hi, thanks for your reply.

Here is the link to the form on the landing page: https://books.callistopublishersclub.com/author-questionnaire-4

I haven't had trouble with it being filled out on that landing page, but when I send it through email (with the recipient's email in the URL) the submit button doesn't work. Here's the format of that URL, maybe this is what's wrong? https://books.callistopublishersclub.com/author-questionnaire-4?email={{contact.email}}16px 

 

Regarding removing and re-inserting the submit button, I don't see a way to edit that in Hubspot. I'm attaching screenshots of what I see in the editor--there is no pencil or trash icon when I hover over the submit button like there is for the other fields.

 

Thank you so much for your help!Screen Shot 2021-09-20 at 8.59.29 AM.pngScreen Shot 2021-09-20 at 8.59.34 AM.png

0 Upvotes