Lead Capture Tools

Vedant
Contributor

Submit button not working for a group of users

Hi,

We have been seeing an issue with of our HubSpot forms on the website. A group of users have reported that the submit button isn't working for them particularly they are not able to submit their information and it's really concerning to us.  

 

Upon checking, everything seems to be working fine from the layout of the page to the actual form itself but we haven't had any luck finding the real issue if it actually persists.

 

Also, is there a way to track failed form submissions in HubSpot? We have a zap in place that tracks the form submissions but we aren't really sure if it tracks failed one's too.

 

Thank you.

0 Upvotes
8 Replies 8
Vedant
Contributor

Submit button not working for a group of users

Thanks @franksteiner79.

 

We have indeed reached out to HubSpot Support and as you said they need a HAR file to see where the issue persists. The problem is for the HAR file we are not able to reproduce the exact same issue on our end and hence not able to generate the file and we neither can ask one our users to generate that for us.

0 Upvotes
Jnix284
Recognized Expert | Partner
Recognized Expert | Partner

Submit button not working for a group of users

@Vedant if you have users writing to you that the button doesn't work, can you not ask those same users to generate the HAR file for you?


maka Agency
Vedant
Contributor

Submit button not working for a group of users

Hi @Jnix284 

 

Unfortunately due to the nature of our setup we can't really ask our clients to generate a HAR file for us.

0 Upvotes
Jnix284
Recognized Expert | Partner
Recognized Expert | Partner

Submit button not working for a group of users

@Vedant can you share a link? I am happy to test whether I am able to click the submit button and generate the HAR.

 

Any indiciation from your users what broswer or device they are using?


maka Agency
0 Upvotes
Vedant
Contributor

Submit button not working for a group of users

Sure. Here's the link to the page: https://www.dataminr.com/request-a-first-alert-account

0 Upvotes
Jnix284
Recognized Expert | Partner
Recognized Expert | Partner

Submit button not working for a group of users

@Vedant the submit button works for me, I'm on Mac OSX Ventura with Chrome 107. Without knowing what browser your users are using, it would be impossible to attempt to recreate the error.


maka Agency
Vedant
Contributor

Submit button not working for a group of users

Thanks for looking into this. I really appreciate it.

 

I'll try to reach out to one of our users if possible.

0 Upvotes
franksteiner79
Top Contributor

Submit button not working for a group of users

Hi @Vedant 

 

As an Enterprise user I would highly recommend raising a support ticket with the HubSpot Support about this.

 

They will want to know on which machine, OS and browser your users experience those issues and probably need a HAR file from one of the affected users to help you. So I would collect that information in advance.

 

I am not aware of a way of tracking failed submissions. When you say that users reported that the "submit button isn't working" it sounds very much like a browser issue to me.