Redirect to URL after submitting Hubspot form not working

MarkCCC
Member

Hi everyone, 

After strolling through a lot of the posts already to try to find a solution to my problem, i couldn't and hope someone can help please as I am not very technical at all. Feels like the issue is to do with either HTML code or my website. 

 

I've created a hubspot form and embedded on my website (https://contextcapital.com.au/old-publications) via HTML code. When i tested it by submitting the form on my website and hit the submit button, nothing happens. It does not redirect the browser to the URL i specify on hubspot. it just stays on the that page. it does create a new contact in hubspot as intended. The purpose of this is after website visitors submit the details on the form, it redirects them to this page (https://contextcapital.com.au/publications-download) to download papers. this page is hidden on the website but it works.  the website is hosted by Godaddy.

i've tried clearing caches and cookies, incognito tab and different browser but the form won't redirect to the intended URL.

 

Any help is appreciated. 

Thanks, Mark

4 Replies 4
TiphaineCuisset
Community Manager

Hi @MarkCCC 

 

Thank you for reaching out.

 

I'm wondering if this could come from a conflict with some javascript. I want to tag some of our experts on this - @tjoyce @BootstrapC @Alex_ do you have any thoughts for @MarkCCC on this? 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


webdew
Top Contributor | Diamond Partner

Hi @MarkCCC ,

You can check this article here- https://community.hubspot.com/t5/Tips-Tricks-Best-Practices/Troubleshooting-non-HubSpot-Forms/td-p/...

that goes through the steps as to why it is not collecting

 

One common reason is that the tracking code has not been installed correctly on the website so I would recommend you to go to the page and troubleshoot if the hubspot tracking code is firing.

 

Hope this helps!


If we were able to answer your query, kindly help the community by marking it as a solution.

Thanks and Regards. 

0 Upvotes
tjoyce
Recognized Expert | Platinum Partner

@MarkCCC - This issue is caused because your HS embed code into an iframe. Your form is going to render in an iframe as well. 
I have previously answered a similar question here https://community.hubspot.com/t5/Lead-Capture-Tools/Hubspot-Form-Not-Redirecting-To-URL/m-p/414214

MarkCCC
Member

thanks @tjoyce for the explanation but appreciated if someone can take a look at the embedded code below and advise how to get around the iframe within an iframe issue as i am not tech savvy with codes. tried contacting godaddy support but no luck. they are pushing the issue with the form not the website and unwilling to troubleshoot. thanks

 

<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/shell.js"></script>
<script>
hbspt.forms.create({
region: "na1",
portalId: "7811008",
formId: "c988472b-3dbc-4430-b335-341714697055"
});
</script>

0 Upvotes