Pop up form not showing

AliceDC
Member

Hi community,

I'm trying to implement a pop up form on my website but it's not showing at all.

I've checked all the possible explanantions:

- my tracking code is well installed on the page

- the options are ok

- My chat is not at the same place as the pop up (chat is in the corner left and the pop up in the center)

 

The only thing to know is that it's a wordpress with a shopify connected. 

 

Did someone already have that kind of situation?

Thank you by advance for your help,

 

Alice

0 Upvotes
5 Replies 5
MatthewShepherd
HubSpot Employee

Hi @AliceDC 

To help troubleshoot, could you share a screenshot of the settings for your pop up form and the URL you are trying to display the form on?


Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
AliceDC
Member

Hi Mathew,

Thank you for your help, here are some information on my pop up:

- I'm gonna have 3 pop ups for the newsletter (one for each store: CA-EN/CA-FR/USA) but I"ve tested only one at a time and it didn't work

- My test is on a specific URL because I didn't want to show the pop up to everyone, just wanted to test if the pop up was actually working on my website. At the end, the pop up should visible on all pages. 

 

Here is the URL for the test on CA-EN for example: https://www.bestar.ca/product/u-shaped-desk-pedestal-hutch-52414/?variation=41 

 

So here is the screenshot of my settings: 

AliceDC_0-1637003786923.png

Please let me know if you need more info,

 

Thank you,

 

And here is the URL used: 

MatthewShepherd
HubSpot Employee

Hi @AliceDC 

I can see from your source code that you are using a WordPress Caching Plugin such as WP Rocket. This appears to be caching the HubSpot tracking code script, and I'm wondering if this could be causing the issue?

<script type="rocketlazyloadscript" data-minify="1" data-rocket-type="text/javascript" id="hs-script-loader" async defer src="https://www.bestar.ca/wp-content/cache/min/1/7816362.js?ver=1637000846"></script>


Can you try excluding the HubSpot tracking script from being cached and see if that resolves the issue?


Matthew Shepherd

Senior Inbound Consultant

Professional Services | HubSpot

He/Him

linkedin.com/in/matthewshepherd/
https://www.hubspot.com/services/professional
ddevi
Participant

As I was too having similar issue but it got fixed as I removed the HS tracking website script. Thanks Mate!

AliceDC
Member

Thank you Matthew! I will check with my team and let you know!