Marketing Grader not updating

SOLVE
Highlighted
New Contributor

Facing some issue with marketing grader update. it is showing an error. can someone please suggest a solution.

marketing-grader.png

 

 

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
HubSpot Employee

Hi @shivani,

 

The Marketing and Website Graders scrape your website to generate all of the data, but in order for it to be successful, it has to scrape the website in 10 seconds.  If it's unable to do so, it will time out and display the error message that you're seeing.  The 10 seconds isn't necessarily the amount of time that the website must load in, it is how much time these tools have to find all of the information.  It looks like because of the complexity of your website, the tool is sporadically unable to crawl the website in time.  When I tested simpler websites with less Javascript, the error message never displayed.  

 

With all of this being said, I was able to update the marketing grader after a few attempts, and after refreshing the tool a few times.  

 

Brett

Reply
0 Upvotes
4 Replies 4
HubSpot Employee

Welcome to the Hubspot Community @shivani and thank you for your question!

 

Can you please try clearing your browser's cookies and cache?  I was just able to go to the URL in the web address bar of the screenshot that you sent and the page loaded correctly.  

 

If that doesn't work, can you please let me know if Website Grader works?

 

Thanks,

Brett

Reply
0 Upvotes
New Contributor
hello Brett,

i tried doing this again after clearing cache and cookies as recommended by you.

Website Grader is working for other websites, but not for our company website "mediaguru.com". Error message appears.

Can you please help on this.
Reply
0 Upvotes
HubSpot Employee

Hi @shivani,

 

The Marketing and Website Graders scrape your website to generate all of the data, but in order for it to be successful, it has to scrape the website in 10 seconds.  If it's unable to do so, it will time out and display the error message that you're seeing.  The 10 seconds isn't necessarily the amount of time that the website must load in, it is how much time these tools have to find all of the information.  It looks like because of the complexity of your website, the tool is sporadically unable to crawl the website in time.  When I tested simpler websites with less Javascript, the error message never displayed.  

 

With all of this being said, I was able to update the marketing grader after a few attempts, and after refreshing the tool a few times.  

 

Brett

Reply
0 Upvotes
New Member

i have the same issue with cissltd.com only reporting #error .....no contructive feedback as to why.  it doesn't seem like i am waiting 10 seocnds to get the error/feedback - but maybe.  any suggestions appreciated,

Reply
0 Upvotes