How do I get all tracking data from a form embedded in WIX?

TGoicea
Participant

Hi all, I really hope you guys can help, as I have been looking for a solution almost everywhere.

 

Our website (www.insightout-analytics.com) runs on Wix, and we capture leads via embedded HubSpot forms, as well as pop-up forms.

 

With pop-up forms, we get all info into HubSpot (info from the form, contact source, visits), but with embedded forms in WIX, we are missing all the contact sources and visits.

 

To be more specific, for embedded forms, the contact source is always 

"Direct Traffic from www-insightout-analytics-com.filesusr.com/html/xxxxxxxxxxxxx.html", and the number of visits is always 1, and pages viewed 0.
 
How can we get all tracking data into HubSpot? This is critical for us.
 
Many thanks in advance!
 
4 Replies 4
TiphaineCuisset
Community Manager

Hi @TGoicea 

 

Thank you for reaching out.

 

I want to tag some of our experts on this - @tjoyce @Jonno_Price  @BootstrapC do you have any thoughts for @TGoicea on this? 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
Jonno_Price
Top Contributor | Platinum Partner

Hello.. 

The key is ensuring that the HubSpot JS is firing on all pages wherever the form resides. Can you confirm that you've followed the steps here to ensure JS is firing correctly? 

Hope that helps and please do come back here to let us know! 

================
Jonno Price
Growth London Ltd.
Platinum Hubspot Solutions Partner
TGoicea
Participant

Hi Jonno,

 

Thanks for helping out on this! Yes, I can confirm that we wenth through the process and everything is set up correctly.

 

Best,

Tudor

0 Upvotes
Jonno_Price
Top Contributor | Platinum Partner

Ok thanks for the update. That is interesting because if the HubSpot JS is firing correctly on the page where the form resides then it should pick original source attribution. There must be some kind of issue with the iframe. 

 

Couple of things to try:

- Could you implement Google Tag Manager on the website and then add your HS tracking script to fire on this page specifically and see if that changes behaviour?


- try the method mentioned here 

- you could also try to replace one of the HS forms with a Wix form and then use the HS <> Wix integration to see if you capture source and analytics that way




================
Jonno Price
Growth London Ltd.
Platinum Hubspot Solutions Partner