External URL not redirecting

SOLVE
New Contributor

I recently updated the URL for one of my forms and updated the external URL (which takes you to the updated PDF). The link works when I test it, but when I complete the form the link redirects straight to the Google search engine home page. Can someone help? The URL works when I test it in another browser so I'm not sure why it won't work when I submit the form.

Reply
0 Upvotes
1 Accepted solution

Accepted Solutions
Highlighted
Community Superstar

Did it work? Is it fixed? If so, please mark as solved. Thanks

 

Note: HubSpot is a constantly evolving platform. Please check the date of each post and view all solutions in that context -- see Marketing Hub Enterprise 2020.

 

Hope that helps.

 

Best,
Frank


Support • Web • Apps • Training

HubSpot's Hiring World-Wide!

Reply
0 Upvotes
6 Replies 6
Highlighted
Community Superstar

Sounds like a bad link used in the Form Options page. Redirect links must be 'perfect'. Double-check.

- see image

 

HubSpot Form Options: Redirect LinkHubSpot Form Options: Redirect Link

 

 

Note: HubSpot is a constantly evolving platform. Please check the date of each post and view all solutions in that context -- see Marketing Hub Enterprise 2020.

 

Hope that helps.

 

Best,
Frank


Support • Web • Apps • Training

HubSpot's Hiring World-Wide!

Reply
0 Upvotes
Highlighted
New Contributor

Hi Frank,

Thanks for getting back to me. I'm not sure what I'm doing wrong with the URL. I'm copying and pasting it from the Files section in Hubspot and I also tried copying and pasting from Wordpress. This the URL when it redirects straight to Google: https://www.google.com/?submissionGuid=888dec06-1926-4bc7-a643-5180bda38a05

 

This the URL within the form (picture attached).

 

 

 

 

 

form.PNG

Reply
0 Upvotes
Highlighted
Community Superstar

Sorry @ldavidson ... didn't see this message until today.

 

Confirmed, the following link works fine ...

https://www.hanweck.com/wp-content/uploads/2019/05/HAN_HedgeFunds_0419cf.pdf

Also confirmed, the HubSpot Pop-up on your homepage appears to work (different PDF).

 

Recommendations ...
- clear your browser cache (i.e., both Chrome and Firefox).
- use the HubSpot CDN link (from HubSpot Files) as your redirect link.
- test your form from an incognito window (in Firefox).
-- never test from the browser instance you use to access HubSpot.

 

Give us a link to the form if you're still having trouble and we'll test that as well.

 

Note: HubSpot is a constantly evolving platform. Please check the date of each post and view all solutions in that context -- see Marketing Hub Enterprise 2020.

 

Hope that helps.

 

Best,
Frank


Support • Web • Apps • Training

HubSpot's Hiring World-Wide!

Reply
0 Upvotes
Highlighted
New Contributor

Great. Thanks so much for the help!

Reply
0 Upvotes
Highlighted
Community Superstar

Did it work? Is it fixed? If so, please mark as solved. Thanks

 

Note: HubSpot is a constantly evolving platform. Please check the date of each post and view all solutions in that context -- see Marketing Hub Enterprise 2020.

 

Hope that helps.

 

Best,
Frank


Support • Web • Apps • Training

HubSpot's Hiring World-Wide!

Reply
0 Upvotes
Highlighted
New Contributor

Hi there,

 

I'm having a similar problem with my embeded form on a Google Sites website. 

 

I've managed to get the form to show on the page if I add <div> before and after the embed code. Without the <div> it will not show. 

 

Now that I can see the form I'd like to redirect to another page on submission - a "thank you" page which I'll use as a goal in Google Analytics. However the form will not redirect to the external url once you hit the submit button, it just stays on the page with the users info. 

 

The redirect url is https://www.acdmarketing.co.uk/home/thank-you

 

I've removed the Captcha, thinking this may be inteferring, but its made no difference. 

 

Any advice please?

 

 

 

Reply
0 Upvotes