English Newsletter form showing up in Greek

ACaine
Member

Hi 

 

One of our forms (newsletter form) is set to display in English, however it is showing in Greek for some people. I think it may only be showing Greek for windows users. Does anyone know how to solve this issue so that it shows in English for everyone?

 

Thanks!

0 Upvotes
8 Replies 8
natsumimori
Community Manager

Hi @ACaine , thank you for your post!

 

Is it possible that those people are setting Greek as their browser language?

 

If not, could you please share the following information for further investigation?

  1. Screenshots where we can see form in Greek (to verify what is the behaviour)
  2. Page URL where this form is inserted (You can send it to me via DM)
  3. When you say "newsletter form", do you mean "HubSpot standard form"?

Thanks!

ACaine
Member

Hi 

 

Thanks for your resonse. 

 

No, it is showing up in Greek for people who's browser language is English and the rest of the website shows up in English. The issue is with our newslettter signup form here.

 

I have attached a screenshot.F4E9AC71-F5EF-4839-BDBD-0F246EC658BF_1_105_c.jpeg

0 Upvotes
natsumimori
Community Manager

Thank you for sharing the screenshot.

I had my colleague with Windows to check your web site and they observed the same behaviour. I am bringing this to the internal team for further investigation. Let me get back to you once I have more information to share. Thanks!

natsumimori
Community Manager

Hi @ACaine , 

 

The internal team investigated and they found that the font used on your form was "symbol". Because this font is available on Windows OS, Windows users saw the symbol fonts. However, this font is not avilable on macOS, therefore, it falls back to the default font and macOS users including myself didn't see symbol fonts.

 

That said, the solution is to change the font by following these steps:

Go to your form edit page > [Style & preview] > [Style] > [Font family] > Change font

 

Could you try this and let me know how it goes? 

0 Upvotes
ACaine
Member

Hi 

 

Thanks for looking into this for me. However, this is an issue that Hubspot need to fix as with the free version it will only let us change the font for one of our forms, and we have already done this. Why is the set Hubspot text the symbol one if it has issues? We are unable to change this and we of course cannot upgrade simply for this issue, when this is an issue that Hubspot could fix by changing the set font to one that does not cause issues on certain computers. 

 

What can be done about this?Screen Shot 2021-10-25 at 13.38.22.png

0 Upvotes
natsumimori
Community Manager

Ah I see, thank you for the details. I think you will need to change your default font in the Settings page:

  1. [Marketing] > [Forms]
  2. [Styles]
  3. Under [Font family], select other font
    Settings.png

By doing this, you should be able to change the default font for forms, and moving forward your forms will be in the newly selected font. (Please note that this change won't affect to your existing forms. After changing the font, you will need to create a new form in order to use the newly selected font.)

ACaine
Member

Hi

 

We have changed our defult font however this form has not changed. Do we need to recreate the form or should it have changed to the new defult font automatically? 

 

Thanks

0 Upvotes
natsumimori
Community Manager

Hi @ACaine ,

 

Yes, so as per my previous response, the change will only apply to newly created forms and not to your existing forms. 

So I'd recommend recreate your form with the new font. I hope this clarifies!

0 Upvotes