Embedding forms on a Umbraco page

JonasRytter
Participant

Hi! 

I am trying to embed Hubspot forms on a website made in Umbraco. When I add the embedding code to a field where I can edit the code, and click OK, the code after <![endif]--> is deleted automatically and nothing is displayed in the field.

 

Is there a way I can fix this? I am not a developer, nor do we currently have a web developer on the team.

 

Looking forward to hear your answers!

4 Replies 4
TiphaineCuisset
Community Manager

Hi @JonasRytter 

 

Thank you for reaching out. 

 

I'm not familiar with Umbraco and unsure what could be happening, can you send us a screenshot of how it looks like? 

 

Also tagging @tjoyce - did you come across this before or have you got an idea what could be happening? 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


JonasRytter
Participant

Hi Tiphaine,

 

Thanks for you message. This is how it looks when I c/p the code in and press OK, and how it looks when I reopen the code editor. I have tried without the <if> statement in the beginning as well.

This is how it looks when I c/p the text in  - then I press OKThis is how it looks when I c/p the text in - then I press OK

This is how it looks when I re-opens the text editorThis is how it looks when I re-opens the text editor

0 Upvotes
TiphaineCuisset
Community Manager

Thank you @tjoyce 

 

Thank you for your reply @JonasRytter 

 

I did some research online, and while I don't understand everything in this thread it seems script is being filtered from this source code section in Umbraco. 

I'd recommend reaching out to Umbraco support how you could add script tags on your page. 

 

Thank you!

Best

Tiphaine


Saviez vous que la Communauté est disponible en français?
Rejoignez les discussions francophones en changeant votre langue dans les paramètres !

Did you know that the Community is available in other languages?
Join regional conversations by changing your language settings !


0 Upvotes
tjoyce
Recognized Expert | Platinum Partner

@JonasRytter - Since IE support has officially been dropped by MS, I would just remove the following code

<!--[if lte IE 8]>
<script charset="utf-8" type="text/javascript" src="//js.hsforms.net/forms/v2-legacy.js"></script>
<![endif]-->